Nswitch not "attaching" right joycon

Hi all.
As the title says, I replaced the PU chip and the small transistor near it, the switch saw the joycon for maybe 20 seconds.
I replaced again, 40~45 seconds.Anyway, I was able to pass the initialization setup
I replaced both a third time, no changes.
Useless to say it’s not cable /ribbon issue as I replaced it twice.
I thought the previous ic I was replacing were bad until I went out of stock, then resoldered the same ICs and it worked the same and stopped.
I removed and resoldered again and the same occurred, 25~39 sec then stop.
I can do it again and again…
So to me it looks like there’s something prior to the PU chip that is damaged but I’m unable to find what.
Any advice?
Sorry for my bad English :slight_smile:

I forgot to mention that if I leave it for a day or two days, it will show as “attached” again!
This morning it stayed attached until the screen turned to sleep mode.

I would use heat resistance tape to tape up the surrounding area of the joycon motherboard and reflow the main IC. I have fixed a few with just reflowing the main IC. Remove the “abxy” or “up/down/left/right” conductive sticker before reflow.

Im not sure, maybe this could help. (diode mode, red on ground)

Thanks for taking care of my pain.
But the joycon has no problem.
I’m having 2 right ones that are working very well on another nswitch.
This switch came in stuck in initialisation screen asking to insert the 2 joycon.
I change the PU ic to complete that setup.
Before that, whatever I tried was null.

Here is one board where I removed the PU and the nearby transistor