PS4 Slim Error CE-35888-2

I am getting this error on a PS4 slim that a customer brought in because they were getting the error after an update. I’m familiar with this error when the daughterboard doesn’t match the mainboard on non slim models, but this is a new one to me.

System will not update or reinitialize after trying between each of the following steps:
Tried entirely different, known good disc drive
Tried swapping cables from known good drive into OE drive
Tried a different HDD

The weird thing is that it gives me the option to update, recognizes the update, copies the update over, then throws the error. With the reinitilialization option it throws the error as soon as you select the option.

Is the bluray drive working? Does it take discs?

Because this customer was trying to do an update there is no way to get it booted up to see if the drive is reading. All I know for sure is that inserting a disc will turn on the system, and the motor works.

In my experience this is just a really weird time for this error to present.