Switch board no longer booting

Hey all!

I bought a damaged switch board as I have a number of working consoles just in need of a new board.
So, when I first got it, it looked awful, but connecting it to a screen and working battery, it was able to boot to the OS.
So, I cleaned it all up, and started on the obvious repairs:

  • Replaced USB
  • Fitted USB Fuse
  • Fitted 2 USB filters
  • Replaced Left joycon connector.

At this point, it was still working as much as it was before, and I could find no obvious shorts, and the rails all gave the resistance values I expect on my meter. But I was not able to get any response from the charger. 0 amps drawn… or moving between 0, 0.02, 0.05, etc.

So, at this point I reflowed the M92 and swapped out the BQ.
This is where something went wrong. The heat needed to get the BQ off was also enough to have all the part on the under side of the board decide that the magnets on my board holder needed to be visited.
I didn’t lose any, so I put them all back in place. The light sensor didn’t survive, so I fitted the one from my parts board. The fuel guage had also moved a bit, so I just fitted a new one.

At this point it was not booting. Black screen, no backlight. No response from computer when connected with no emmc.

The only off reading I could find, was that now the 1.8v rail sometimes shows as a short of 0.8r, though sometimes didn’t and shows something like 3k.

I figured that it had to be something in the areas that I had been working on, so checked on my parts board which things connected to that line. As such, I then removed M92, (no change), removed BQ, (no change), removed the little 6 pin mosfet (?) on the rear side. This this point it initially still showed the short. But after it had cooled down it was back to reading 5k (my normal). But it was still not able to boot. So I put back on the BQ chip, but still not booting.
I put back on the M92 at this point, and the reading dropped back to 3k.

So, I think the M92 needs replacing, as it is dropping the reading, but I also believe I should be able to boot without it.
I can replace the 6 pin from one on my parts board, but again, I think this is used for the joycons, so I would expect to be able to boot without it.
This leaves me to think that it can only be the BQ (which was new) or the fuel gauge (also new, and fitting went well).

So, I guess I think I could do with some advise at this point before I make things too much worse. In the mean time I am going to go through some of the posts that covered issues in these areas and check some readings.


Ahha! I was just double checking the soldering and noticed a tiny crack in the fuel gauge. (on the under side corner, so couldnt see it before). Replaced at again veeery carefully, and it does indeed now boot!

Still not charging though, I will check to see if 1.8 is reading correctly now, if not I guess M92?

Latest update on this, I swapped out the M92, though it didn’t change the readings. I then double checked the USB port and it wasn’t happy again, so I removed and refitted it and gave it a good clean.

I now have it charging and detected by the PC in one orientation, but not in the other. This suggests to me something on the USB still, but using the USB testing board I have continuity to all points on the board. Is there anything else on the board that can make it only work one way?

Check the diodes near the USB and compare your readings to Calvins charts.

failing that, I had a board recently, everything checked out including the diodes, M92 etc etc but somebody before me had done the USB connector, they charred all the plastic (a pet peeve of mine) evidently the high resistance across the pins (due to the charring) was enough to ensure charging in one orientation wouldn’t work, just threw an “unable to charge” message in hos, I could get it to work 1/10 times, so I switched out to a new USB connector and everything works fine now.

Thanks for the info!
Just on the off-chance I changed out the USB again. Confirmed that all pins has continuity, and resistance was low, mostly around 1r, apart from D+/D- at about 3r. Checked the filters, all were at 1.5r. Checked the capacitors above them, all read at 100nf or so. Wasn’t convinced pi3 was all the way flat (I hadnt touched it, so previous owner?), so reflowed while pressing down and I was right, it wasnt… but it didnt help. It still only charges one way.

I will have a check of some of Calvins diode readings next. But I find it really weird that it doesnt respond at all in that direction, with 0 amps and no message on screen.

So, I have been poking at this board again recently. I forgot that I had already changed the M92, so changed it again. Didn’t make a difference.

I removed the 6pin diodes that are not always populated, no difference.

Re-seated the USB again, nope nothing.

I then decided to go about testing everything else, and found that it wasn’t detecting the left joycon at all.
I re-did the connector as some of the pins seemed lose, and it had got a bit charred. Its now solid, but it didnt change anything. I checked for continuity from top of the connector to a joycon rail, and it seems good that end.
My plan so far is to find where these go on the board to see if all the work in this area has damaged the vias. Do you have a continuity map for this side? I have so far found one for the right joycon but not the left. If not I will have a dig around and build one myself.

Forgot to mention that I have swapped out the PU chip on the back… should I swap out the little 5 pin chip just below the connector?

Can you take a diode mode reading on the D+/D- TP’s near the USB in both probe polarities relative to ground and the same again on the other side at points cluster A - 10 and 9 and let me know the readings?

Think I mapped out the otherside, I think @jkyoho did the other one of a single side of the board but can’t find the post, Via damage does seem to be more common this side of the board due to the lower thermal mass and people over reworkng BQ… though, don’t think this issue is gonig to have any relation to your USB issues.

I would also unscrew the joycon rail and remove that steel dowel pin and check the contacts directly as it’s not uncommon for them to get hit in liquid damage cases if you haven’t done so already.

If i remember rght this IC is isn’t present on some of the other board revisions (though I need to double check this) which implies it’s protection, probably a diode package, think if it’s not shorted to ground it’s fine to stay :slight_smile:

Ok, so the test points on the front, I get 0.8v on both pads with red probe on ground, and 1.32v with black probe on ground.
On the back side, with red prob on ground one is 0.5v and the other 0.51v, with black probe on ground, one is 1.09v the other 1.25v.

This board didnt come with a shell, so is being tested in one with from another unit, I have a few, so I will try some more just in case, but I dont think its a rail issue at this point.
The 5 pin chip doesn’t short to ground, so I guess I will leave it alone for now :smiley:

I have also just managed to test from the joycon rail through to the point in the other side of the board by the PU chip, and it has continuity at 1r.

joycon fpc conn mapping?

This seems like too much of a deviation to me, typically they would be practically the same.

These two are from the USB straight to the M92 IC, perhaps there is some junk in the USB or around the M92 pins skewing this reading slightly, if you have a known good board verify these readings just incase it’s just your meter or something :slight_smile:

Yeah, that was my feeling too. On my other boards they both read at the higher value. I checked continuity from there to the M92 and it looked fine.

If you’ve given everything a good scrub at USB/M92 and the readings remain the same, pull the M92 IC and make sure both those TP’s read OL then go from there

Ahha, so I pulled the M92, and the reading on the “off” pad was not OL. So I pulled the USB also, and it didnt change. Presumably there is via damage that is partially shorting it to ground.

Is the move here to cut the trace to its via, and run a jumper?

Typically, I removed the diode again, and now it shows OL…

Haha Sods law, maybe your meter has a high enough VF to get a reading on this diode package, my meter doesn’t.

I’d just retrace your steps now and install the M92 IC and see if those pads give the correct diode reading in both polarities, then reinstall the diode and do the same, then the USB :slight_smile:

So, I have now put back the M92 and USB leaving the diode off, and the values read correctly and it is now charging both ways! I think I will just leave the diode off, my spares board doesn’t have them.

I also noticed while working on it, a chipped corner on a small bga chip just above the realtek one. Any ideas what issues that would cause?

It will work fine without it, just note in the event of future USB issues this diode may well save the SoC

guess this is the ENXX IC? responsible for producing 3V3PDR, as the Switch is booting it must be present, should be fine :slight_smile:

Glad you got it sorted :smiley:

Awesome, thanks for the info :). Now I just need to re-test the left joycon…