Switch Not Charging, Loosing battery while docking, Bad performance

Hi guys, I got a “water damaged” switch a couple of months ago for repairs, I managed to pretty much resurrect it, however it has a couple of problems I cant really figure out why.

  • 1º The screen is dead, need replacement (waiting for china screen to arrive :confused:), touchscreen and everything else work as intended. (I dont really think this is bad or so, but maybe is related with the problems below, so just commenting it)

  • 2º The Switch doesnt seem to charge on its own, I can charge the battery with some Lipo Balanced chargers, but the console itself doesnt seem to charge the battery on its own. I kinda traced back the problem to the BQ23193 chip, but the chip doesnt show any sings of being faulty, and all the values are correct.

  • 3º Probably related to 2º the switch while docked has an absolute terrible performance, resulting in low fps, audio and video desynchronization, etc. Cant really trace back this one too, I have checked the video chip on the back but everything seems good, also M92T36 doesnt seems to have any problem, im kinda lost in 2º and 3º to be honest.

Like I said everything else was fixed so it could be any fixed part that have been damaged that is causing this, but I dont really know how to trace it, and all the fixed parts seems working as intended, no sorts or so are apreciated in any part of the motherboard (hoping im not loosing on some of them). Any help will be greatly apreciated.

Have a great day, Raul.

Have you checked all of the capacitors around the charge chips and video chips for shorts?

No, I didnt find any schematic or have any other motherboard to compare to, so i dont really know the values of those, but they dont seem to be sorting.

Replaced the screen today, I dont really know if the screen is bad, or i fucked something up, or something is diying on this Switch, any idea @tronicsfix (btw, still not charging, will try replacing video chip probably)

youtu. be/ZKIpzVZilIY (remove the space, seems i cant post links for some reason :frowning:)

Unfortunately, there’s no way for me to know. If you check the capacitors for shorts to ground it will help you solve the problem.

I did check today every single capacitor in the motherboard, no sorts. Im starting to think maybe the battery is bad or something, but the battery charges normally outside the console, so i dont really know anymore…

On the tester is drawing 0.02 A…

0.02amps seems too low mate you might want want to check things make sure they are functioning right

I’ve seen M92T36 bad without any shorts. I’d probably try that if it was me.

Thanks mate I couldn’t remember the name but that’s what I was thinking of I hate it when you can’t remember something but you know that’s possibly where the fault could lie

1 Like

Hey there,
I’d also bet on the M92T36 being broken, because 20 mA is a way too low current draw. Should be in the single Amps region if charger allows, but at least a few hundred milliamps. I’d try replacing that the M92T36.

1 Like

Hello all, sorry for the late reply, have been sometime for the parts to arrive.

For future people if someone ever face this problem, seems that it was something wrong with the bq24193 chip solder pads, had to replace it and clear the old solder pads behind the chip, which were kind of burnt (not caused by me, I can assure).
So finally managed to get it working after a couple resolderings, however the actual chip I got in there is second hand and some times fail to start the charge, but repluging the console seems to fix it most of the time, so I will stick with it from now, as it seems to work anyway.

Have not replaced the M92T36 since I dont think there is anything bad with it, the console now charges and work as expected, so it should be ok.

So marking this as solved, thanks everyone for the advices and help. :slight_smile:

2 Likes