Switch Not outputting video when in dock

Hey fixers,

I picked up a switch off ebay that somebody else tried to repair. The unit didn’t power on.

I replaced the Pl3 usb chip as it was crooked from an attempted repair it looked like. I also added a line from a pad that was lifted to the filter. They also blew off some caps around the VCC on the opposite side of the chip. As they were decoupling caps and I didn’t have .1nf around in that form factor I just crossed my fingers.

It powered up and worked no problem, but then the USB-C would only charge one way. It looks like they also replaced the USB-C connector but they were consistent enough to mess that up as well. None of the exposed pins were actually soldered to anything, they all wiggled. Also when I plugged it in the dock it didn’t do anything, the screen stayed on and no green light, nothing on the tv.

I reworked those pins on the usb-c and now the unit charges either direction.

Now when I plug it into the doc the screen goes blank like it should but still no output to video.

I have a new USB-C coming and I ordered those caps.

Its all I can think of doing at the moment. If anyone has suggestions I would love to hear them.

Thanks!

Sounds like you’re on the right track. You’ll want to make sure and double check all the filters around the video chip as those can blow too. Most likely the USB C pins on the inner row are not connected either.

Sounds like a video chip issue mate maybe indirect if you get primary video because the dock is secondary