Switch v2 no picture on TV (checked all the caps)


I tried to fix Switch v2 which had a problem outputting image to the TV. When I insert the switch to the dock, the green dock light turns on and the TV changes to the correct HDMI channel (HDMI-CEC function). The charging also works via dock.

I used original dock and charger. The dock works with another switch.

The USB-C port and the pins looked fine but the console itself was a little bit bent. I did not try to replace the USB-port.

I checked that all the capacitors around the three ICs’ (P13USB, M92… and BQ…) were fine. Also the chokes/filters connecting to the P13USB were fine also (continuity test).

Any idea what other troubleshooting I could’ve done, except for the USB replace?

If the dock works fine and outputs a signal to the tv with an other working Switch, I would inspect the pi3usb on the Switch farther.
My problems with no signal to tv till now have been related to a bad pi3usb or bad contacts at this ic. As you say that the Switch is bent, my guess is, you will find missing contacts.

Values are in diode mode, measured with no battery, no charger connected and red probe on ground.

Consoles with bends are typically as a result (but not always) of bad USB installs, people (wrongly) heating from the top and then putting downward pressure on the USB connector (because they have to, as there is not enough heat penetration) as the board doesn’t lay flat when they push the connector down and as the solder solidifes the board warps at the tail end, this leads to further issues down the road particulary with joycon vias and ram.

If you can take a picture of the USB from the backside (p13 side) then i can confirm if this is the case.

Check the filters above the p13 IC and ensure continuity from one side all the way up to the chip, then check with USBC breakout

Hi Calvin, that diagram is super helpful. I had to return the switch to the owner today, so I cannot troubleshoot it anymore. The switch originally had cracked LCD problem because it was dropped and they needed the switch it just for handheld usage.

Anyway, they might send it back later, so I’ll continue inspecting it next time.

I tried to attach picture but I cannot edit the original post for some reason. And it does not allow me to add pictures nor links to the replies…

Severence, I’m sorry, I didn’t take a picture of the motherboard, but I’m 99% it hadn’t been soldered.