TIL: No boot? Check if RCM'd

So I had a customer drop in a Switch that needed a charge port.
I replace the charge port, check under the scope and all pins are clean and soldered on.
I go to charge it, it’s pulling 0.40amps - OK, battery is clearly depleted.
Leave it on charge for three hours, and still charging at 0.40amps… hmm that’s odd.
Try to power it on, nothing. So I try a known-good battery, still nothing.
No boot logo or animation, no charge indicator… hmm.
We’re getting 3.8v to the battery, so it’s definitely charging… this is a weird one I’m thinking.

So I send the customer a text, “Hey, the repair is done but we are waiting for it to charge up so we can test everything then complete the job”

The customer replies, saying that “Oh, I forgot to mention but the Switch has auto-RCM enabled so you won’t get anything on boot without injecting a payload”

Oh, this explains a lot. Sure enough, plug it into a PC and it is detected. Boot into Hekate and we have a working Switch. Yay! I wasn’t going insane.

After all that stress it was as simple as an auto-RCM causing no boot logo or charge indicator. This got me thinking about repairs @TronicsFix had done, where there is just no power even if it successfully appears to be charging. Especially with eBay purchases of faulty units - check if the unit simply has auto-RCM enabled and try to boot into Hekate!

I thought I would share this with you all, as a laugh, but something to keep in mind. :slight_smile:


Thx for your share !:sweat_smile:

Hey there,
cool, thanks for sharing :slight_smile:

1 Like

I have literally tried everything. I have Sx OS with auto-rcm on(I think, I honestly can’t remember), but I cannot get my computer to detect the switch. I have replaced the battery, checked for corrosion, and everything seems to be fine. All I get is a black screen. I have tried booting into sxos with the dongle, without the dongle, hard resetting, still nothing. I am at a complete loss. When charging my volt meter initially read 15v @ .5amps, I don’t know if this is correct or not. Could it be a bad charging port? Even if it is, why wouldn’t the 2nd battery work? I really don’t want to have to send it off as it’s still on 5.0.1 firmware, but it looks like I may have to :(.