Weird? Nintendo switch got charging icon, But not charging

Got a HAC CPU 20 v1 nintendo switch which i’ve been doing for a week now, unit is working as normal, it’s just it doeans’t charge, when i plus original charger, it shows a green charging icon, but battery level not going up, Hooked it up on a voltmeter, and its just shows just .5 amps compared to .43amps in a normal working switch. things ive already check.

  • Changed m9 power ic twice
  • changed bq ic once
  • changed fuel gauge once
  • no short on ground on components
  • tried a different battery doesnt make any difference
  • check usb type c continuity for each points all good
  • readings on power ic normal, 3.2v on pin 5,6 1.8v on small cap below
  • getting 15v on both sides of the fuse. voltage actually reaching m9 power ic.

anyone got an idea or same issue? just want to know where to look out next. just not familiar with this kind of issue on this switches. TIA

I assume this is with the official charger. What about with with a standard 5v charger? They use different data lines.

tested it using a mi powerbank with pd support, usb plugged a voltmeter, only shows .5amps on meter.

I was thinking non pd chargers.

on a 5v wall charger, im just getting .05 or .02 amps. weird coz when i boot hecate payload, it goes up to .14amps, still not the usual .43amps in a normal working nintendo switch.

How does the battery page in hetake look?

battery information using the switch original charger, it seems really weird coz it’s charging in hecate, and batt level is going up gradually, but using a non pd charger only shows a charging symbol.

check your d+ d- data lines if opened or chock filter broken

data lines got continuity from bottom point 2 and 3 up to the other end of choke filter, i can inject payload, switch displays the charging icon on both type sides of the type c.

The battery design capacity got only 1000mAH from picture seems weird to me.
Check this post, see if any info help

actually i already tried using other battery, just the same result, same hecate batt info shown, running out of ideas, already changed usb type port as well, and tested it after using a breakout board i bought from aliexpress, just changed my BQ ic again.

Whats the diode reading on d- and d+?

on my multimeter it shows 780 on both D- D+ red probe on ground.

now the board is not powering on, no shorts, but just noticed something off, on the capacitors under the bQ24193 ic, i dont get any value in diode mode. compared to a working board, wondering if this is connected to a rail, coz i already tried replacing the bq ic and and the capacitors from a donor board, but still no reading.

The BQ IC isn’t soldered properly… clear indications of over rework (evident by the charred board on edges) reserve this as a donor at best …

Hey bro ,

  1. my wall charger <> wire <> male usb typec port
    → when I cut the wire … there are 5 wires … I am trying to understand those wires … the multimeter is not helping … could u please help me … i want to know these 2 things:

a) how these 5 wires are connecting to the female usb typec port
b) I think the switch console needs 5volts “x” amps and the nintendo dock needs 15 volts “x” amps

Any help on this part ? please let me know …


except charging ic , try remove the Ziner Diode at the bottom left corner of the BQ and try again what’s the result . hope it’s help .