0.41a, no screen, possible fix

so I’ve had a couple of motherboards that will only slow charge and have no display. From following Steve’s videos I was under the same impression that these motherboards couldn’t be recovered but today I managed to recover 1 (well I have fast charge back and the display works).

Normally you will get 5v but only 0.41/0.42 amps and it stays steady at that ampage and doesn’t go to 0 amps before switching to fast charge (1.3 to 1.8 amps depending on amount of charge in the battery).

This was a water damaged board (milk actually and what a stink when I opened it up!), so I haven’t put it back together until I check for corrosion and I need to replace a capacitor I lost when changing the chip. I did put it back together enough to confirm the display now works and the unit is charging.

The problem seems to be the 77621AEWI chip located below the main chip, next to the speaker connection. it’s a little black chip surrounded by capacitors. I was going to add some pictures but don’t have the option.

I used a doner chip from another knackered board and had to reball using flux and a soldering iron but it’s not too difficult to do, especially if you can see the reballing is good using a scope.

I also noticed that when I removed the 77621AEWI chip I got an open loop on both sides of 1 of the capacitors next to the charge chip BQ24193 (one of the larger ones to the left hand side of the BQ chip). Once I added the doner chip this short disappeared and for the record this capacitor wasn’t shorting with the knackered 77621 chip on the board. This kinda indicates that there is a link between the main charge chip and the 77621 chip.

I thought I’d open this topic as it might help others get around the 0.4 amp no display problem. I have another board here somewhere with the same problem and when I get a chance I’ll do the same fix and see if I get the same results.

1 Like

I unfortunately can not report the same success from a donor board. I will see about ordering a new chip and trying with that.

Thanks for this info. I’ll have to try this out sometime.

Please Google “Auto RCM”
How to detect it , how to inject payload to disable it for the unit to boot “normally”.

I think I got lucky with this original switch as I’ve tried this fix again and it doesn’t fix the problem.

What I have found is that if you take a good Nand board and plug it on to a switch that has the 0.4a no display problem you can get the switch screen to come on and the battery indicator to flash up for a second or 2. (proves Backlight and LCD are working as least).

This will be because the nand isn’t paired with the switch so will not boot all the way. This could mean that if you could get the files off the suspect Nand board and flash a new Nand board then most likely the switch could be recovered.

I put a Switch into RCM mode for the first time today so I’m a long way from figuring out how to flash a new/spare Nand but maybe someone else has some ideas.

I’ve got a couple of Switches here that show the 0.41A, black screen, slow charging, no AutoRCM, no shorted caps/rails, dead to the world. Steve’s commented on the video that he doesn’t yet know of a fix.

From what I’ve determined they are stuck on POST where the power subsystem is triggering a fail and not releasing the CPU to boot. I’ve been focusing on M92T36 and in particular pin 17 which is labelled as GPIO1 ALERT# which is a discrete signal, normally high on working units, but is pulled low on both units exhibiting the same issue. My current theory is that this chip, or a companion chip within the power subsystem is flagging a discrete error, causing POST to fail.

Pin 17 from boards that have the M92 show the track seems to go to a couple of test pads and nowhere else. Either way it may be a clue here.

I’d be really interested in other fixers who have come across this issue and whether they get a similar read on Pin 17. Thoughts?


-I am in the same boat: 0.46A, slow charge, no AutoRCM, no shorted caps/rails, dead to the world. I just looked at my pin 17 test pads on the M92T36 and mine is low (0V).

-Are we sure the Pin 17 trace only goes to those test pads, or is there a via underneath the chip that leads somewhere else? If there are no other components that could pull this signal low, my guess is that it’s a M92 debugging output to let us know something isn’t right.

-I looked at both sides of my board under a thermal camera and the only heat I observed was coming from the SoC/GPU. Probably normal, but I’ll need other fixers to verify that for me.

-As far as I can tell, all of my power rails are good. I’m measuring 312mV on VCONN_IN on M92 pin 36, which I thought was odd. There is a “PP5 705” mystery chip that has 5V coming into it and 312mV coming out, which feeds M92 pin 36. I would be curious to know if that is normal on a working device.

-Here are all M92T36 test pad values I’m showing on my dead device:

Pin 11 - 2mV
Pin 12 - 3.28V
Pin 13 - 2mV
Pin 16- 22mV
Pin 17 - 0V
Pin 18 - 1.81V
Pin 19 - 1.79V
Pin 20 - 1.79V
Pin 22 - 10.9V
Pin 23 - 10.9V

I would be curious to know if any of these besides Pin 17 do not match a working board. I’ll let you all know if I find any other clues.




I’ve been working some more on this one for the last few days. I’ve not lifted any chips yet as I’m keen to statically diagnose this. I’ve got three units with the exact same failure parameters, so I’m keen to find a fix.

Having taken a look at videos showing the removal of M92, there doesn’t appear to be any evidence of a via from pin 17, however I think I’ve found evidence of a via under the pad of pin 22 (S2_SRC) as it’s connected to the test point between the pair of SN1814 mosfets (S2, Charger Power) nearby. Whilst it doesn’t confirm for pin 17, it does suggest that the designers have used hidden vias under pads in some cases.

As you say - whether it’s connected or not, pin 17 being pulled low on all three boards is something unique to them. Working switches pin 17 is always high at 1.8v. Would be good to hear from anyone else to confirm this absolutely.

On my three boards with a Samsung charger and battery connected:

Pin 11 - GPIO5 0V
Pin 12 - GPIO4 3.28V
Pin 13 - GPIO7 0V
Pin 16 - GPIO0 2mV
Pin 17 - GPIO1 0V
Pin 18 - VDDIO 1.8V
Pin 19 - SMDATA 1.8V
Pin 20 - SMCLK 1.8V
Pin 22 - S2_SRC 4.8V
Pin 23 - S2_G2 10.7V
Pin 36 - VCONN_IN 0.3V

So pin 22 looks different between your readings and mine, however that’s part internal charge pumps for of the Power FETs, so they will likely fluctuate. VCONN on my working boards is around 0.3V.

Your PP5 705 is a PP5 822 on mine. PintGlass has been asking the same question on BadCaps with no answer. He thinks its a dual P-channel mosfet.

1 Like

Actually, I was reading BadCaps wrong. Post ordering inverted. PP5 is a ROHM UT6J3 Power MOSFET.

@ Denny - What is your pin 7 reading on your duff unit on M92? Both of my faulty units, they are same as VBus. On the working units, this is 0v…


I gave up on this and sold the duff unit for parts. After speaking with the owner more in-depth, I learned that he was using AutoRCM to push game mods to the unit, so I decided that the firmware was bricked and that I shouldn’t spend any more time on it. In a last ditch effort to fix, I downloaded TegraRCMGUI to try to detect the device in RCM mode - no luck. My Windows 10 computer would give the USB connect/disconnect sound with each press of the power button on the device, but gave a “cannot recognize USB Device” error message each time I plugged into the USB port. I tried more than one cable with no luck. I threw up my hands and decided it was permanently bricked.

I never measured pin 7 before I sold it - sorry I couldn’t help you out there. Thanks for the feedback on PP5 and your measurements.

Best of luck to you - if you solve this there will be many repairable Switches!


1 Like