14 hour repair, 5 parts and still same problem!

So I got a switch that was not charging (still had enough juice to run), so I thought to myself, piece of cake. Opened, checked the M92T36 chip and it was short. Swapped it. Plugged in, and saw some magic smoke come out. I quickly unplugged and inspected for shorts. Found the video chip was fried. The filters were ok. Swapped the video chip and the USB port.

Now: Switch does not draw any power from the USB port. I charged the battery and tested the mobo, the switch runs fine. Only issue is the original issue I had, only now I made it worse. Before, my USB tester would light up and tell me voltage/amps and other info. Now, the USB tester wont light up, some sometimes lights up for a split second and shuts down. The Switch shows it got a flash of power then as if the cable is unplugged.

I know what you are thinking, I did a bad USB port swap, so I did it again. Same result. So I swapped with another USB port, same result!

I am at a loss. Help me diagnose this please.

Oh, and there are currently no shorts anywhere. Besides checking for shorts, I checked

  • Continuity for filters
  • Continuity for fuse above USB port
  • Continuity for Coil to the right of USB port

Any other suggestions?