2002-2629 error when insert cartridge

can’t read any game cartridge.
so i checked the cartridge pin and cable. can’t find any fault it was very clean.
also checked the short around the cartridge area and found inductor and capacitor shorted to the ground just under the cartridge connector. i doubt ic is bad next to this inductor. Can someone check value of this inductor and capacitor?
it shouldn’t read ground isn’t it?
i couldn’t find this ic chip in aliexpress where I can find this chip?
it says 83169s59 on the surface of the ic chip
i wanted to upload pic but I couldn’t

I just checked a board and found no shorted caps under the connector… The inductor should be shorted on both sides.

Chip on mine has 8316 0585 which I actually think drives the LCD. If you follow the trace of the cap to the left of the inductor it connects directly to the LCD FPC.

Thank you!
I rechecked it the caps was not shorted and only inductor was shorted to the ground.
because it was near the connector. Yes you are right it was LCD driver and should no related to game cartridge.
I checked all pin values of cartridge and found nothing strange. I don’t know What to do now

I found sometime read about above 3.000 value on pin 26, 28 on ALC5639.
it’s headphone L R line. it normally should read around 1.4 resistance mode, isn’t it?
what strange is sometimes it read 1.4 and sometime read above 3.0. i don’t know when it change. but always change.
headphone line also same connector with game cartridge. so i think something related to

I had twice the same error. In both cases it was a problem with the firmware version of the card reader. After update the whole system to a newer firmware the error was solved.

Thank you!
update is just an update switch via wifi?
i updated to the latest 15.0.1. but still same issue.

i might update without inserting the card reader on motherbord.
want to try but
how can I re-update with the insert card reader? now it says firmware already latest and no option of update.

Sorry, I have no further experience with this error. I had the error twice at two differnt Switches and solved each with updating the Switch to the newest firmware. In my case the problem appeared because I didn`t take care of which game card reader belongs to which Switch and mixed them up.

when i got this switch already had this problem. I don’t know the history of this switch.
I opened it for observing the motherboard. I might update without inserting a card reader and I’m not really sure it was or not. it can be. I mean I remember updating it.
You have this issue with a different card reader it means they had different firmware? or switch can’t swap card readers?
I tried a different card reader, and also error 2002-2629 is still the same.

i success to fix error 2002-2629.
スクリーンショット 2022-12-31 2.56.56
was an open line. probe to a pad under CPU and made a jumper.
now no error and read the cartridge.
Thank you!


@jiiko2361 Could you describe exactly what you did? I have the same problem.