275ma boot UART error 80910020

Hi All! Working on a EDM-010 that had an issue with 2.0v line. That was corrected, then I got a 275ma boot sequence. I replaced the SSD controller, no change.

I finally got my UART setup. I’m getting an error I can’t find any information on. Has anyone come across error 80910020? The list of errors only has a 80910002. The error is being reported whether or not the SSD controller is installed.

I also took another board with a proper boot sequence, removed the SSD controller and ran UART. There it only come up with error 80870003 error after safe loader, which I am also seeing on the board I am working on, no 80910020.

Removing a SSD memory ic generates a 80871055 SSD bank error. On the board I’m working on it does not.

Any ideas what I should look at next. Thanks

I didn’t come across the error code 80910020.
Did you check the SSD RAM ic?
Btw did you check for more than one error code?

After my post, I tried swapping that out too. No luck. Still the same error. I cleared the error log and check errlog 0,1,2. At error 2 I get all F’s

The power lines for the ssd are all present?

Stand by voltages look good. I’m seeing 2.5v and 0.8v when powering on the unit. Any other voltages I should should see?

There should be 2x 1.2v at the pmic

1.2v is also present. Sure wish I knew what that error was. What are your thoughts on changing the southbridge? It’s strange that it doesn’t report an error when the SSD memory is removed when I have another board that does.

From my point of view (so I’m not entirely sure) the southbridge is checking step by step the communication/power of the sub systems. If an error appears, it will stop at this point and don’t go further, no matter which later sub systems may cause another error.

If I pull the wifi ic. The only error output will be 80C00136. If the SSD controller is removed, while the wifi is pulled, the error is still the wifi error and not an SSD error.

Things on my mind:

  • the filters on the lines SSD controller ↔ APU (are they reading fine?)
  • does another error appear if the ssd pmic is pulled?

Filters look okay when comparing to another board. I pulled the SSD PMIC and got a bunch of new errors related to HDMI. However 80910020 error is gone. Pictures are before PMIC pull (did not reinstall) and after.

The second image is
80810001 - General power failure
C0160203 & C0160303 seems to be: SSD controller problem/data line short circuit/power failure

The funny thing is, if SSD pmic is on board and you short the power lines at the spots on my second image, these errors appears:

short at 4: 80910002
short at 6: 80910200
short at 7: 80912000

I can provoke
C0160203 and C0160303 if the ciruit above F7502 is shorted to gnd.

I couldn’t find the C0160203, 303 that was posted in the error code for UART so I looked at the file in the PS5CodeReader utility, saw the message attached below and assumed it was related to the HDMI. Good thing I ran out of time yesterday and didn’t go chasing that.

Uh oh… I originally started with an issue on the 2v line. It was shorted to ground. I replaced the IC and 5v and 2v came up. I will have to check this area again later today.