Asking for some help to asses damage on V2 Board

Im new to this forum and repairing switches.
I´ve done 2 sucessfull repairs on V1 and now I´m encoutering some readings I can´t really put in place.

General. Switch is not powering on no reaction on LCD.
It´s loading at 0,4 A but not in fast charge.
When i tell directions i will do it from the bottom up (USB facing down.)

Opening it op i found some signs of liquid damage but not all over the place just at certain spots with no trace where they came from.

  1. at theLCD connector. The contacts of the cable seem corrodet burned in the middle part and parts of the right site. Also some coloring on the fixation bracket of the connector. Pins seem to be fine.
  2. A spot was found on the heat shield of the Wlan/BT Chip

Checking the M92T36 the lower right and left caps where shortened but at around 100Ohm.
Now i was planing to replace it but checked the others on the board also.
Here is what i encountered:

1: The big Cap right left of the LCD connector is shortened.
2. All Caps below the Tegra around the MAX77 are shortened
3. 90% of the Caps on the undersite of the board are shortened or show readings of around 100Ohm. (I can make a list if this would be necessary)

I currently assume that this board is a total and it ends up as a donor .
But i just wanted to make sure if perhaps somebody has encountered a similar one and give me some advice what i can also check.

Thanks for your support and cheers to the Youtube Vids on the TronicsFix. I was able to get a good ground knowledge thx to them.
(Yhea no native english speaker i gift every spelling error to the one who finds it first)

Hoping for some good input.

PS is there a discord where some of you meet up to talk about things like this?

First, it sounds like the water came in through the game-card slot, so I would also take a very close look at the emmc module. As well as the game card board.

In terms of the other points:

  1. Do you mean the inductor? If so that is meant to be ground and will read as about a 1 ohm short. The other caps in that area shouldn’t though.

  2. This area is different depending on revision of the board, which board revision do you have? On my board that DOESNT have a similar section over to the left of the CPU, most of the caps are low resistance, somewhere around 20 ohms, but not actually shorted, and two of the inductors are on ground and two arn’t.

  3. I think that sounds OK, on my board half of the caps show about 300 ohms, and half show 70 Ohms, on dead ones they were reading 0.8 ohms.

So… I dont think it is dead, but more investigation needed.

Hi, thanks for the advice.
I will check swap out the USB chip and check again. Have to wait for the shipping. Also waiting for a p13 on another switch where the docking is not working.

So Update.

While checking P13 USB & M92 and after finding no issue i tried replacing P13 USB.
After i desoldered the old one i noticed a trace missing and also that some caps have moved from a prior repair attempt.

I have wired the cap directly to the IC and brought the caps back into place.
(Yhea not all are sitting perfectly but they connected/ Have yet to clean)

Now the Switch is working again except for dockingmode.
(Green light on)

I´m not sure where to look elsewhere for the fault except replacing the P13 again.
USB Port is fine regarding to my circuit board.

Any Ideas?

I would get it all cleaned up and take another picture, or even better, one from each side of the chip. That one very wonky cap looks like it may not be making a good connection but it is hard to tell…

I´ve checked all connections 3 times now and also replaced the P13 again.
Same result it just won´t dock. :confused:

Funny thing is i´ve got a second Switch here that had a bad P13 and a blown Filter.
It also had no docking and fast charge also wouldn´t work.
After i replaced the Filter and P13 fast charge works but docking still won´t work also.

I tried both switches on different docks which work fine with other switches.

Does the M92T36 have something to do with docking?

This is really starting to frustrate me.

Do you have charging on both sides of the usb c port? I had a switch that didn’t Dock because of that. I replaced M92T36 and the short was gone. After that the switch docks fine again.

Yhea on both the charging works fine in both ways.

So I guess I´ve to give a try to replace the M92T36 and see what happens.

Well well i´ve now blown 2 replacement M92T36 and the Switch. Won´t boot completely with error message.
So I wont tackle the other switch until I´ve found out whats wrong.
There seems to be an issue with anything related to the M92.
Can´t find any issue with the usb port.
But it won´t take a charge now.

I wondered if anybody here has used vaporized resin to find shortcuts in this cases yet?

For docking, it is usually related to p13usb, would you be able to touch up on all the solder joints, sometimes it looks like it is soldered together but it is not. I would search the forum for the p13usb diode and see if you get those numbers.

I would take out the p13usb first, then fix the m92 + bq for fast charge and then go back to soldering on the p13usb.

You could use a PSU and vaporized resin or with a thermal camera or just IPA.