Black screen after first nintendo logo

Hello. I got in a nintendo switch that stays at a black screen after the first logo. It is stuck “on” but no backlight or image, I have to disconnect the battery or hold the power button to shut it off and try again. I have already tried the obvious faults, plus, I have tried downgrading (just in case it was a bad update).After downgrading to 6.0, it would boot to nintendo switch second logo and freeze on it. This consle had not been opened, nor modded/hacked). Here is everything I have tried/checked:

  • It charges at full 15v. Is in fact charging.
  • Booting into Hekate works, I can select boot cfw, or boot ofw, doesn’t matter, gettting the same issue.
  • Booting without p13usb, and with a new one, same results
  • Booting with a new m92t36, same results
  • Booting without m92t36, got the second logo for a split second, then the number error that appears when m92t36 is missing, so I decided to try antoher new m92t36, and got the exact same result (black screen after first logo).
  • Booting without lcd connected, Same exact issue, I can tell since the backlight comes on once for a second, then shuts off.
  • Downgrade to 6.0.0 following manual downgrade (I have done this succesfully before). Durring the first boot up step, I get stuck at the second logo, I have manually erased the user memory, and restored the system partition, it doesnt matter, just freezes at the second logo. If I try and boot ofw or cfw through hekate I get the same first issue (black screen after first logo).
  • As an act of desperation, I have tried applying pressure on the SoC, didn’t make a difference.
  • Measured the voltages from the max chip on the back, I have all voltages: 1v01, 1v1, 1v35, 1v8.
    -Measuring the max chip on the left of the SoC, I get no output voltage, I believe this is the GPU voltage, but not sure. If I am correct, this doesn’t turn on until the second logo (that I don’t get), but wanted to mention it in case I am wrong.
  • Measured various caps for shorts around m92, and around the wifi chip, haven’t found anything abnormal.

So the only thing that changes the error has been removing the m92 chip, giving a split second of the second splash screen, but I have treid 3 different m92 chips, (1 known working) and always back to the same issue.

Ps. I have restored the original nand backup, no longer downgraded since that has been discarded.

Any Ideas? Thanks in advance!

So, after reading a bunch of other posts with similar issues, it seems that if it is not the m92 chip, and no obviouse damage/missing voltages, then it is un-repairable (unkown).

Can any body confirm this?

check or try replace this ic behind the battery inject port , its will happen what u was mention too if this ic faulty.

after replace and changing if still same , means no fix .

Thank you for the response, but I do not think the fuel gauge is bad, in Hekate I can see all the battery data, and it discharges to empty and charges to 100% without an issue. Unless it could still be the fuel gauge, I would prefer not to swap it. I have also now swapped the BQ chip, just to try, but same issue.