Black screen after Nintendo logo, but this one is weird

Hey folks. I have a V1 unpatched Switch here that I modded with a trinket m0 chip about 2 years ago. Everything was working fine until recently, and now if I power it on (sysNand), the Nintendo logo appears followed by a black screen. In Atmosphere, it gets past the first Nintendo logo but hangs at the “Nintendo Switch” logo. I can get into hekate without any issues.

But here’s the weird part… if I clean the area around M92T36 with a drop of IPA and qtip, then power on, it boots up fine in all nands! Once it’s on, everything is completely normal. It charges, plays games, docks properly, connects to wifi, etc. Something is causing this console to fail the second phase of the boot process, but what could it be? Furthermore, why does it work when I clean the area with IPA?? I can only assume that this process is creating a temporary short and somehow “resetting” the chip, but who knows.

Things I’ve tried so far:

  • desoldered the trinket chip. no change
  • replaced M92T36. no change
  • checked for shorts around all of the usual suspects (BQ, M92t36, PI3USB). None found
  • checked the eMMC info in Hekate and it reads fine
  • checked the battery gauge in Hekate, and it looks normal
  • tried a different known working battery
  • checked voltage on pins 5 & 6 on M92t36. They’re reading 3.3v
  • tried with and without sd card. same behavior

Any ideas on what the heck could be causing this issue? Obviously it’s not ideal (or safe) to keep cleaning the M92 chip before powering on the Switch, but I’m at a loss here.