Black screen after Nintendo logo different versions

Hi,

I was wondering if someone can give me some advice on this issue.

I purchased a faulty Switch and after looking at the switch (unpatched) I was able to get into hekate, but it refufed to even try to boot into the normal firmware. So did a firmware rebuild with 8.0.1 due to hekate stating 9 fuses had blown. But it still wouldnt boot, after looking over the board I noticed the max77621aewi had a slight chip in it so changed the chip.

The Switch then started up & I thought I had fixed it, but after the Nintendo logo I just kept getting a black screen. So I was confused to what maybe causing the issue.

I went back and checked today on the backups of the nand I had done just in case I may have missed something and discovered that the rawnand in NxNandManager is reporting the firmware has 10.0.4 & that autoRCM had been set to ON.

Can someone confirm if this maybe why the switch is not booting??

Cheers

I had one like this. My problem was the tiny resistor(theres two there) next to the soc shield towards the left. I think theres many othwr reason that can cause this too

Stuck at the Boot Logo is often a WiFi Chip problem.

Its located under the metal shield under the NAND.

Try reflowing it. There are also some Videos on YouTube about this.

Can you give anymore details where this is please?

It’s not stuck at any logo, it goes from Nintendo logo to black screen. It doesn’t even get to the switch logo, which on research is if it’s switch logo and gets stuck is the wifi / Bluetooth chip.

I had two times a problem with a nand. The Switch passes both logos and it takes minutes to show HOS. In hekate I could see with the read/write test that the nand had a very bad read/write speed. After copying the whole nand to an other, both Switch‘s worked again.

I am going to test the nand hopefully tomorrow as I have to fix the sd connector & I do have a spare nand which I’ve restored the backup to.

Pic attached

I have the same issue as you, have a switch that is stuck on the nintendo logo then crashes / black screen. Amp draw goes to zero at the moment it black screens then starts slow charging again, however the switch is non-responsive and requires a hard reset (hold power button or unplug power). I thought it was a wifi / bt issue too, but I was able to boot into linux and tested that the wifi / BT and audio were all working.

I then thought it was an issue with the emmc module. I’m able to get into hekate and dump keys. I then proceeded to take a donor emmc module and rebuild the nand (upgraded firmware, higher than fuses blown) with the keys dumped. Same issue, stuck on nintendo logo then goes to zero amp draw, crashes.

Now, I’m at the point where I’ve decided to change the ICs on the board potentially something could of causing this. I changed M92, same issue. I’m going to change BQ once I figure out how to protect the plastic connectors tomorrow.

Very interesting, I may give Linux a try lol.