Black Screen, No Shorts and not responding to some payloads


looking for ideas to fix this tablet.


  • Charges fine
  • Detected by TegraRCM in the PC.
  • No shorts around M92T36, P13USB, BQ
  • Pin 5 and 6 of M92T36 theres voltage 3.xV
  • Pin 18 of M92T36 1.8v
  • ENXX IC - 1.8v on resistor, 3.3v on Caps
  • No display, No backlight, just black screen
  • Don’t know firmware version
  • Dont have a backup of keys

-Checked caps around M92T36, P13USB, BQ, no shorts
-Replaced M92T36
-accepts payloads but only showing black screen
-Hekate, lockpick = black screen

-biskeydump v9 using cmd prompt [ TegraRcmSmash.exe -w biskeydump.bin BOOT:0x0 ]
i get this screen, tried multiple screens

-Tried 2 different screens and batteries.
-Switch gets detected by TegraRCM

Smashed the stack with a 0x7000 byte SETUP request!
Payload successfully injected

but theres no responce on screen

Ram or Ram joint issue most likely, possibly the SoC.

remove the SoC shield cover and try putting slight pressure on the Ram ICs while Biskeydump is loaded, if the graphical artifacts change or go away then that’s confirmation, try a ram reflow in that case.

checked the emmc pins and getting OL on pin 25 (DAT3), on good board getting 0.54X.

is DAT3 used by the Switch or just DAT0?

pinout from

I’ll try pressure on the RAM.

Yeah, that’s definately a problem, (though it’s completely seperate to the grpahical glitches your seeing) Switch uses all data lines, which increases r/w speeds, it won’t boot stock OS without all of them afaik, if this is a liquid case, then I would closely inspect the traces and Vias at the EMMC and ensure theyr’e all intact as that’s most common, after that would be impact and ball/joint issue.

That being said, I don’t know off the top of my head what these lines measure in circuit and on the EMMC out of circuit, so that might be worth confirming, as maybe it’s open SoC side or maybe there’s a series passive open on this line (sorry don’t remember if there is)

I would take care of the graphical related issues first though and worry about the EMMC later.

some progress i put pressure on the RAM and nothing.
then put some pressure on the SOC (side facing RAM) then the geen graphical glitches turned to black/white lines. but error remained.

next i decided to put pressure on SOC before sending payload and it loaded all keys.