Blank screen after 2nd Logo / takes long to show logos

An other defect Switch. :stuck_out_tongue:

After pressing the power button it takes too long aprox 15 secs to Nintendo logo, 45 secs to Switch logo and then after aprox 120 secs a blank screen (backlight on but nothing on the screen).

Tested so far with Linux (L4T Ubuntu) and assumed as propper working: wifi, bluetooth, audio (speaker/headphone jack/tv), touchscreen, docked (output on tv) and charging (slow/fast).

I m wondering if it s a hardware or a software issue.

I’ve had a couple of boards with very similar symptoms. They fast charge but hang on the second logo, the only difference being is they remain on the second logo and never go to a black screen.

Check the two capacitors middle left of the SoC are intact. Check the row of passives in front of the WiFI IC shield are all good.

If nothing, I’d back up the EMMC, then go through the whole manual upgrade/downgrade process to rule out a FW issue.

Failing that the fault on my two boards was related to SoC issues and I believe it was down to impact damage, both resolved after a reball.

Also probably unrelated but I’ve noticed if you put in an exfat formatted SD card into a system which does not have the exfat driver it will cause quite a delay at the second logo, if/when the system boots it will then throw the error about the exfat card.

Out of interest can you get into the service mode holding vol up and down at boot?

I can enter the ‘recovery mode’ screen. It takes a while, but the service mode menu screen is following the blank screen. After ‘factory reset without deleting save data’ the Switch reboots to setup and after finishing the setup I get to the homescreen, but still the same long times.

I updated to the newest firmware, but still the same.

For testing I inserted a game card, it started and the game is full playable without any problems.

The both tiny caps beside the soc and the components in front of the wifi shield are intact.

To reball the soc I need more soldering practice. Now I m happy that I m able with two or three attempts to reball and resolder the max ics. :smile:

Hmm this is interesting, so now following the system factory reset it will boot to th HOS homescreen and is otherwise working other than for the delayed startup?

Maybe the EMMC is failing and is the reason for the delay, do you have another spare module you can copy the data on to for a test? I believe Hekate also has a built in EMMC speed test which might show issues in this regard.

Failing that, I would check resistance to ground on your 1V8PDR and 3V3PDR perhaps they could indicate a potential issue on these rails.

Completely understand, if you do wind up going down this route at some point, don’t use solder paste but instead use the preformed balls as the IC is too large for paste and it’s a complete nightmare as it’s too difficult maintaining even pressure on the stencil in combination with the paste

1 Like

Thanks for the hint. :smile:
The problem is the original EMMC. I made a backup and restored it to an other EMMC via Hekate. Now with the replacement EMMC the Switch is booting normal.

Glad you resolved the issue.

Interesting though, never had an EMMC fail in this manner. Wonder if there is software which tells you the number of read/write cylces (maybe for SD/MMC) perhaps there was a software or hardware related issue which caused erroneous reads or writes wearing it out… though I would only expect such a case on liquid damaged boards.