Boots on battery, but turns off when plugging charger (15V, 0A)

Hey everyone,

I have this Switch v1 that I’m trying to fix (purchased on the French equivalent of eBay, so… pretty dodgy). When probing the USB port in diode mode, some readings were wrong. So I removed the port, and that’s how I realized it had been worked on before. Most pads had been ripped and replaced with wires and solder mask. To be fair, whoever worked on it did a pretty good job.

After removing the port, a lot of readings were still wrong. Turns out, some filters, caps, and P13 were dead. I changed them and most readings came back to normal apart from D+ (open) and D- (shorting to ground).

I followed everyone’s advice on this thread here https: //www . I can’t remember whether it was @Calvin or @Severence who suggested to check continuity across filters and on the back of the board. Filter was fine, and following the tracks across the layers, it led me to the SoC. So I’m guessing the data lines on this one won’t be repairable. Nevermind, it’s still technically usable without it.

I tried booting with a charged battery. It kept crashing after the first logo. So I changed the fuel gauge and it booted fully (and there was much rejoicing, yay).

I fixed some traces on the USB port, chucked a new one, and tried charging with the adapter. It instantly shut down the Switch. My ammeter was reading 15V, 0A.
I had to unplug the battery to revive it. I assumed it was maybe M92 ou BQ, as it is charge related. I changed them with “new ones” from Aliexpress, so not 100% reliable. However, it didn’t work.

Any ideas?

1 Like

Never mind, it was another case of “cheap/fake M92”. Swapped for another one, and now it works.
Too bad for the data lines though: it was a v1.

Aaaaaand it failed again (I think). It’s not charging any longer. It still displays the charging symbol, it still docks but only on one side.
Should I try yet another M92 chip?

Check the full gauge chip. If he is faulty he prevent the battery from chargeching.


Point : full charge inteference

Did you try to use another battery?

Good luck.


First thing I changed, as it wasn’t booting at all in the first place. It’s however possible my soldering was bad, as I didn’t properly reballed the chip. Since there are only 9 pads, I assumed I could get away with only tinning them.

You’re right, I’ll take a second look at it.

I did, it’s fine.

Yes please pay attention again ;)maybe the resistor or cap is faulty. If you can use hekate you can see the informations about charging in the tool section. Maybe you can find there the more infos.


I wish I could, but since the data lines are blown, I can’t. Which is a shame, of course.
To be honest, I’m not sure it’s going to be the fuel gauge: it’s rightly displaying the percentage on the Switch and the charging symbol appears when plugged in.

I’ll give it a go anyway.

Hi again,
Maybe the usb port pins are bent and/or bridged.


They look fine under the microscope, and I’ve also tested them on the breakout board.

What if it were the FETs, though? I have the right voltage until the first FET, but on the plane between the two power FETs, I get 0V. What do you think?

I also don’t have any voltage on pin 6. I think somewhere I read it was delivered by the EN chip at the back.

Did you check the video?


Could you check the readings on the FETs? If some of these has 0V, could should be that he is faulty? Could it be that the switch was water spilled?

could you make a photo of the board with the maybe faulty FET?


Funny you bring up this Youtube channel, I discovered it last weekend. The video on power management is really insightful.

Everything looks fine… and everything was working fine this morning, drawing a healthy 0.47A… until just right now, where the current draw is all over the place, going from 0.00 to 0.04, up to 0.47 again…

The overall charge went from 20% to 44% in about 40 minutes (that’s when it started behaving strangely)

Strange :wink:
And which FET is faulty and has 0V?

I know, right?

Sans titre

So the gate is low on one of the FET (the other one is fine), and therefore is not opening, which I guess is causing everything to malfunction.

VEX is faulty, the gate pin is at 0V, so everything seems to be pointing to a faulty M92. But what do I know…
I have a few chips coming, so I’ll swap it again. Hopefully, it’s not going to die instantly.

the voltage comes direct from USB. So that should the issue here.
The FET or the MT is faulty would i guess.

Check the screen:


Yep, everything on that red line is present, so no fault here. The gate on the FET on the right hand side has 7V. The gate on the left-hand FET has .4V. So I’d bet against the M92T36 chip. As soon as I grab replacements, I’ll give it a try.

1 Like

Hey there,
I finally got the new M92s.
So I reballed the fuel gauge, just in case. Nothing changed.
Then I changed the M92 chip, and now it seems to be working.
Thanks for your help @RedScorpion!

Hi Vince33,

that sounds great :wink: Thanks for your feedback!


1 Like