BSOD after failed USB replacement

This switch has had a failed USB port replace attempt. The repairer has used most likely some kind of acidic flux.

The big inductor is fine (checked with LCR-meter). CC2-line (5. from left) is open line (checked the continuity to the test point, test point is also OL). I’m not sure where the line is cut. I could do a jumper wire to the test point.

Anyway, After making sure there are no lines short circuited I plugged the battery and powered on the device… and it’s a blue screen. I’m suspecting there are acidic flux under the lowest RAM. I tried putting pressure to the RAMs&SoC but it didn’t help. Maybe reballing the RAMs will fix it.

What do you guys think. Would RAM reflow be enough?


Via damage due to board layer seperaation maybe because of the excess heat and prying? I see this quite a lot at the P13 and filter area, but looking at how chewed up the through hole sections of the USB pads are this might be the same.

It might be, or the board got so hot and the Ram was sliding about while he was trying to remove the USB, a Reball might resolve if the underlying pads are fine, I’d check your resistance to ground on the 1.1V rail and 1.8V rail of the PMIC in both polarites and compare to a known good, this can sometimes give an indication or confirmation of Ram related issues. If you find something which doesn’t look right, I’d probably do a flux boil with your flux to pull out what’s there, then clean then attempt a reflow of this IC first, check the readings again and see if it’s resolved, if not then a reball might be in order.

Before any of that though I’d just double check the Fuel gauge for any cracks etc I also notice this is a CPU-01 board which likely means it’s unpatched, so best thing to do might be to fix up the USB (or manually wire a USB cable up to it) and inject the Hekate payload or Biskeydump payload which often give nice visual feedback to a likely Ram issue :slight_smile:

Unfortunately the board version is HAD-CPU-01, AFAIK it’s patched, the back plate says the model is HAC-001(-01).

Thanks! I don’t have another HAD-board (yet) to compare with. I think the resistance-to-ground values are fine.
1.8V (top right inductor) gives 1kohm, 2kohm (reverse), 0.36V (diode)
1.1V (bottom left) gives 100ohm, 300ohm (reverse), 0.1V (diode)

I tried flux boiling on the lower RAM but it didn’t help. If I remove the eMMC the screen stays black. Probably in AutoRCM mode.

I think the fuel gauge is fine.
Here’s a video.

I do not have high hopes for getting it fixed.

Ah my bad, yeah it’s Mariko :frowning:

I’m pretty sure with my meter it’s approx 10K/5K on Mariko but I’ll check later, you’ll get comparable results on Switch Lite boards too as they both use the same die, this rail is known to cause issues on some meters so if you have a Lite board handy it might be worth comparing against that.

This sounds normal from memory.

Had a similar case a few weeks ago, had over rework of the USB and P13 area which caused board layer damage which prevented vias from making it to their destinations and also increased the resistance of some lines to the destinations, I manually routed all I could but there was some line/s still open and I suspect it was a line from the fuel gauage and/or BQ IC as they must be taking that same path through a layer past the USB/P13 area, in the end it was easier just to pull the SoC, reball and put on another donor board

Looking at the discolouration of the P13 filters I suspect something similar may be happening on your board :frowning:

While I know you can swap SoC’s between originally patched and unpatched boards, I don’t think you can put a Mariko SoC on a patched/unpatched (erista) board, so if you wanted to go down the reball and transfer route the donor board would also have to be originally a Mariko rev (combined CPU/GPU buck Max IC below the soC)

Bit of a tangent, but I found this the other day, which may help with seeing what damage in this area can effect. Different revision to yours, but still…