Charging but no display

Hi, I’m working on nintendo switch v2. It came broken when I bought it, so I fixed it and always test if the diplay works. I had a problem that the switch was only charging one side and I found out why (2 pins on usb c were connected). And the one I tried to put everything together but when I tested the screen I got a black background with a white bar. So I reconneced the whole thing and now I have no picture in the dock or handheld. The console charges but is unresponsive (And when I turn the charger I hear a beeping sound).Now it only charges 4.76 V and 0,44A. No display, no dock, no backlight

If your USB port is bad / not soldered properly you won’t get dock dsiplay and/or it can cause charge related issues. I’m guessing you changed the USB port? if yes, disconnect the battery and check continuity via a USBC breakout board.

Also worth noting, often times, in cases of bent USB pins the M92 IC and sometimes also the P13 IC can get wiped out, so that’s also a possibility, I’m gussing when you say you saw a white bar you mean you saw the white battery indicator? so maybe the battery is flat as a result of either the dodgy USB port or possibly because your M92 IC is bad.

So, first thing I’d do is, disconnect the battery and check for shorts around the M92 IC, if all is fine then check USB continuity via a breakout board, then after take a very close look inside your LCD connector and ensure you haven’t inadvertently bent any of the pins, I only mention that last one as beginners often bend the LCD pins at least once :slight_smile:

I found short. But I don’t get it, Why it was working kinda ok and now it’s only charging? Btw by bar I mean wrongly connected robbon from LCD. And about that pins on lcd ribbon, yeh they literally bit bent but it was working when I tested them like 3 weeks ago.

Btw short is here

short is on 1V8PDR, pull the M92 IC and see if the short clears.

If the USB pins were bent then that could cause it. It’s not really charging, at 5V it would normally jump to to upwards of 2A which is true high current charging, this won’t happen with a bad M92 IC or dodgy USB port.

Bent pin in the LCD connector can also cause a short on 1V8PDR also, so make doubly sure none are bent prior to pulling the M92 IC.

Ok thx, i will test everything tomorrow.
Btw I don’t have hot air station at home so every time I’m doing something I need to do it in school and I think It’s starting annoying teacher :sweat_smile:

I see, hopefully you can ask your teacher to give you a hand if they have more experience, replacing M92 IC or USB etc is a bit tricky if you’ve not done it before and you can wind up making the situation worse, so it might be better to have someone else do the work (?)

He actually changed usb c for me but he ripped 2 pads a I was researching for schematics and solutions. Btw He managed to fix it btw. Then it was docking and charging one side. After that I found two connected pins and he fixed it. And I tryed tested it (I attached the ribbon incorrectly and when I reattached it, it stoped wotking)

Unless you repair those two pads you probably won’t get dock or charging on one side for good unfortunately. (I’m gussing these pads were on the inner hidden row)

Yeah it might well be just the bent pins in the LCD which are causing the short on 1V8PDR, take a look with your phone cam zoomed in in good lighting, if you don’t see any bent/crossed pins then it’s more likely to be the M92 IC

I think i was lucky about those pads

Btw i think i saw little bit of dirt on one pin. thanks for the help i’ll look into it tomorrow

Ok you were right I ripped out one pin and slightly damaged the ribbon. :frowning: .

But that doesn’t explain the slow charging. Or does it?

The ribbon itself is probably fine, just needs that scorching cleaned up off the pads.

The connector on the other hand is probably toast I’m afraid, and if it were me I’d replace it but you might wanna try bending that pin back into place if you have the patience and giving it a good clean to remove any potential carbon stuck inside which may cause issues. Don’t know what that bent pin is off the top of my head but if it’s a ground pin you may be able to get away with just snapping it off but double check that first… you may find it snaps anyway when trying to bend it back into place.

1V8PDR is a critical rail used by a lot of IC’s including the M92 IC, so if it’s being pulled low it could potentially prevent that or some other IC from functioning and thus no high current charge. Take things one step at a time, resolve the LCD connector issue first and see if it clears the short on 1V8PDR, if not go from there. could also be your USB port install is not good / intermittent but wait til after you’ve resolved the LCD connector issue before worrying about that.

Also, don’t connect power or battery until that LCD connector issue is resolved less more damage be caused.