Charging but not turning on

Hello. I have a nintendo switch that does not turn on at all. If I connect the charger, the battery does charge, but nothing comes on the screen, no backlight, nothing.

I have removed the nand and connected it to the computer and it was detected in tegra. I injected hekate and got and error on the switch screen. This does NOT happen with the nand connected. If the nand is connected, the computer does not detect anything on the usb port.

What does this suggest? I have both 3.3v and 1.8v on nand connector, and no shorts to ground (on the nand 1.8 and 3.3).

The weird thing is, the heatsink gets a little warm when leaving the battery connected.

do you have any shorts around M92 or PI3USB?

No shorts around those two components, always the first two I look at. Plus it is charging, the battery is now full, and if I am correct, if there was a problem with any one of the two, it wouldn’t charge, right?

So far, I have suspected corrupted nand, so I did a downgrade (to reconstruct nand), and I can get it booting v6.0 through hekate selecting boot ofw. But there is a problem, if I update it, it goes through the update, says it is going to reboot, then right back to the same problem. It is not in rcm mode, just black screen. I can get back into rcm mode, inject hekate, but it will not boot any option at all. Nor cfw sysnand, or ofw sysnand. Just black screens. I re did the whole downgrade to 6.0, it worked again, but after upgrading to whatever version is live (probably 12.0.3), it gets the same problem.

would you be able to make an emunand of the working sysnand? and upgrade the emunand instead ? what is the fuse count ( does it match the sysnand) since updating sysnand with choi/daybreak will not burn fuse?

I have tried to make an emunand of both the 6.0 and the 12.0.3, neither will run from hekate, they just show hekate atmosphere logo then black. It does have 15 burnt fuses, so it needs 12.0.2 ofw to run without hekate (which it doesnt anyway). I can only get v6.0 OFW (from hekate) to boot, anything else just give black screen with no nintendo logo (6.0CFW, 6.0 emunand, 12.0.3 OFW (without hekate), 12.0.3 OFW (from hekate), 12.0.3 cfw both sys and emunand) all of these give the exact same black screen.

can you try to rebuild 12.0.3 with emmchaccgen with the original prod.keys (lockpick) on the switch. you need joycon to navigate tegraexplorer for the restore.

I haven’t heard of this, but I will look for a tutorial to try it out, it seems to be what I was looking for to update manually to 12.0.2

I just followed a guide, it is a lot easier than the hacdisk choi downgrade procedure. But it did not work. I created a 12.0.2 FW and used tegraexplorer and scripts to write to the switch. Only black screen.

One thing I have not mentioned is, if trying to boot ofw either from hekate or straigt from turning on, the switch is completley “dead”, not detected in tegrarcmgui. But if I try to boot cfw, the screen goes black after the atmosphere logo, but it is detected by tegrarcmgui. I can reinject hekate payload, and get “panic” error, press power and re-enter hekate menu.

Update. The switch does power on up to v11.0.1 (using hekate to bypass fuses). And I can also get atmosphere to boot as long as I use an atmosphere for v11.0.1. If I use atmosphere made for v12.0 I get a black screen. So the problem is definitely something to do with v12.0 on both OFW and CFW.