Couple of BSOD repairs with the same exact problem right after, no docking

Hi everyone! Long-time reader but just recently signed up, so I guess I’m new around here. I hope to get along well! :smile:

So, I got hold of 2 switches with the infamous BSOD problem. Pressing on the top-right corner of both CPUs got them booting, so I proceeded to reflow them and got them working!

For good measure, I checked the USB ports with a breakout board, and everything is fine. I tried to charge them, and still, everything is good with no shorts around… BUT!
When I tried to dock the boards, neither of them did it successfully, even when I tried to dock them with an extension cable (both sides of the USB port). The green light on the dock turns on, the screen on the switch goes black, but I don’t get any image on the TV.
Thinking if it was the P13USB chip, I checked my diode readings around the chip, and it turns out that both boards have an open line (here’s what I mean):


Following that trace, I found out that it goes under the top-left corner of the CPU. So, I guess maybe a simple reflow wasn’t enough.
I’m wondering, do I have to reball both CPUs, or is it something else?
Thank you for your time. I hope you can help.

If there are no scratches on the line to the SoC, it could be a missing contact or a faulty SoC.

Same issues as yours.I’m starting to thinking that reflow isn’t 100% effective on these motherboards that suffered the bent flex board problem.

Yeah, I guess reballing is the only way to actually try to resolve this issue. However, it’s a difficult job for me since it would be my first time doing it

1 Like