CUH-1001A PS4 dead. Likely APU Problem. Need Help/Advice

I have a CUH-1001A PS4 that suddenly stopped working. It seems the only way to recover my data is to get this thing working again. I’ve tried removing the covers and placing washers under those screws, but it still wouldn’t turn on. It just does the beep/2sec attempt to start. I can keep pushing the power button and getting beeps/attempts to boot, so I assume it’s the APU problem. I checked my PSU just in case and there’s no bugs or signs of damage.
I was thinking about trying to “reflow” the APU with a heat gun. I doubt it will work, but I want to try something since I’ve run out of options.
Any advice?

could you upload a video? sounds like PSU problem… btw, don’t reflow your apu…

I originally thought it might be the PSU, but from the TronicsFix videos and others I’ve watched, it seems more likely to be the APU problem.
This is exactly what happens. Can keep pushing it for a beep then a blue light. I tried the washer fix but it didn’t work.

PS4 On And Off DIY Fix