CXD90026AG APU won’t unsolder despite how long/intense I heat it (using IR lamp)

I have a PS4 original model with BLOD (device powers off immediately after being powered on).
I have tried 3 times unsuccessfully to remove the the APU so that I can eventually replace the APU with a working one (or learn how to do so for the next board I have with the same problem).
I have tried keeping the device preheated at 200 degree Celsius, and heated with IR at 220 Celsius for 10 minutes. After that failed to work, I tried variations of more intense for shorter, or less intense for longer.

I know that my method possibly could cause damage (this is a donor board), but what exactly is causing the solder balls to remain solid?

I am using a T-862++ reflow BGA station, and have used a thermometer to verify the temperature.

Thank you.

You should try a higher temp on the rework station, I would try 270 or so and see if that changes anything. Keep in mind I don’t have a bga rework station, though usually I find it easier to work with solder that is heated 50-80C higher than its melting point