Diagnosing short inside Nintendo Switch

My Nintendo Switch suddenly wouldn’t turn on or charge. Nothing on the screen, no reboot/reset trick I have tried worked.

I often used a normal USB-C instead of the official charger, which might have damaged it.

I tested the current while charging (/w official charger) and got 0.02A without the battery and 0.08A with the battery.

Note: The battery and charger was “known working” and I tested with multiple battery’s and chargers.

I also tested the coil and fuse which worked fine.

I tested all capacitors in continuity mode and one had shorted out (Blue).

Some were showing no reaction, on either side, to ground (Red)

Something noteworthy about the capacitors is how all the larger ones, and almost only the larger ones, on the board, were the ones acting weird.

Could replacing any of the chips or capacitors fix the capacitor short?

Could anyone please help me find the schematics and boardview of the pre-2020 Nintendo Switch?

Thank you!

Model: HAC-001

im having trubble uploding the images. i just get: Sorry, you can’t embed media items in a post.

gyazo , com/0ac8761b20338f43ec6e2ad92f08e9c9
gyazo , com/83c23c34a439e91657cdceebda986133

replace , with . to se images

this might be the same issue as: tronicsfixforum , com/t/switch-not-boot-0-02a-but-no-shorts/4854

Temps after 30 min carging:
Motherbord: ~32C
Nvidia processor: 40C
Inductor: 37C
M92T36: 32C
BQ24193: 35C
Battery conection port: 35C
BCM4356: 33C
All chips on back side: 32C

This are all coils and they should have continuity even if its from signal ground to signal ground like your blue one. :wink:

I would check if the voltage from the usb c reaches the m92t36.

Ok! it lookes like i’m getting votage on the pins around the m92t36 chip. Which mode on the multimeter would i have to be in and were would i have to poke exactly?

Without battery and charger connected you can check in diode mode (RED probe on ground and with the black probe on the pin/pad) for correct values or shorts. A short on the four big caps over the m92t36 are an indicator that the ic is bad.


Got some interesting results.

remember to replace , with .

The short at pin 39 (LDO28) m92t36 indicates that the ic is bad.
I would remove it, check that the shorts are gone at pin 39 and pin 35 (CC1). If the shorts are gone resolder a new m92t36.
The cap at the bq ic is ok. I measured the same at a working Switch.

Okay. Thank You! I will update with results :slight_smile: