Dualshock 4 problems. I've changed out the charging port and board for a known working one as well as a charged battery. Still no life. What's the next thing I can replace or try?

Pretty much as title states. I bought a “for parts or repairs” Dualshock 4 off eBay thinking I could try and fix it as a little project, I have lots of spare parts knocking around. First thing I tried was changing out the port board with no luck, then tried a charged battery and it’s still bust. I assume it’s something on the mainboard that’s gone. I have the tools to reseat chips or change out for another I just don’t no what to try first, or whether there is an obvious thing that blows out, maybe due to using a fast charger with the controller etc. I now know the port I took off it is actually functional as I tested it in my good controller.

Any help would be appreciated, ta.

(Sorry if this doesn’t belong here, couldn’t find a dualshock thread)

Is it a V2? If so there is an IC that is a common fault. It’s an S2PG001A. Only place I could find replacements was Aliexpress and they are expensive about £12.

Sometimes the chip will get hot when you plug it into power.