DualShock 4 v1 won't charge through micro USB

I have a v1 controller that will charge through the port in the front (yellow light goes on) but the light stays off when I put a cable in the back. If I press the PS button while there is a USB cable connected, it sometimes briefly starts flashing red. I tried another battery since this one seems dead and the controller works fine but still won’t charge and still flashes red with a USB cable connected. I also replaced the JDS-011 board that houses the LED and micro USB connector along with the ribbon cable but the issue remains.

My guess is something on the main board might be faulty but nothing really looks wrong to the naked eye. Any thoughts?

I connected the battery that’s out of charge and tried front charging again and the LED is slowly blinking red. The chip to the left of JDM-020 gets hot. ‘Charging’ without a battery results in a faster red blinking. Does slow red blinking instead of slow yellow mean the battery is out of juice and charging?