Dyson V11 Issue post trigger repair

Hey all, long shot here but I have a very expensive issue that shouldn’t have happened. I have a Dyson V11 and after performing a pretty routine replacement of the plastic trigger, the vacuum is no longer powering the brush bar.

I have continuity from one side of the battery terminal to one side of the controller board but not the other. I have continuity from the one power terminal on the main control board to the one side of the plug that powers the brush bar, but not the other side.

Follow link to google photos:

photos.app.goo.gl/EjNLc83VSYr9Viy88

The main vacuum motor is being powered from the battery and is working fine.

This was a very, very simple strip and repair. I have no idea how this has happened. Wondering if anyone has a clue as to what I may have done wrong?? I fear this may lead to a replacement motor and control board.

Thank you so much. Have a great week!

I’ve only worked on a Dyson animal once - though i don’t think it was this model, probably older and it was so long ago i’ve forgotton the inner workings of it so don’t think I’m gonna be much help.

Surely they aren’t using a seperate motor just for the brush roller? do you see any contacts from the hose going to main base unit?

Usually on this style the roller spins by virtue of the suction from the main motor, if that’s the case on yours then they usually stop spinning as a result of hair and dust getting jammed inside and just need taken apart and a good clean, sometimes it might be the bearings holding the roller (if theyr’e not being cheap and actually use them that is) - so if there is no second motor then battery or trigger problem is likely not your issue.

I did see some wanky marketing on Dysons site saying there is “inteligent sensors” on the brush bar motor head, so i guess if you see any contacts for this going by way of the tube to the main body then it could be whatever they are at fault… but who knows with dyson as they are so full of shite :slight_smile:

Well this seems to possibly confirm

Time: 3:58

If you have these contacts on yours, it probably means you’ve got a secondary motor in yours and/or these are for those “inteligent sensors”, - if it’s a motor you should measure resistance across the pins, maybe something like 8 ohm (very very approximate) so you’ll wanna check that and makes sure it’s not open or dead short and of course that the contacts are clean and all that

Next youll wanna check it’s each contact has got continuity all the way up the pipe to each respective pin, then you’ll wanna check that you have continuity from those corresponding contacts on the base unit to wherever they go on the mainboard.

If all that checks out, then I’d be testing the presumed motor on a bench supply to ensure it still spins independent of the base unit and go from there

Thanks for the reply. I wasn’t clear in the OP. The reason I was testing continuity is because I’m getting no voltage at the connector the exits the main vacuum motor control board. Yes, the brush bar has a separate motor but I know that isn’t my issue as it was working before, I’ve tried two powered brush heads and I know I have continuity along the wiring harness that goes through the cyclone assembly to where the wand/brush bar connects. There is not power getting to it.

I get battery voltage at the terminals on the vacuum motor control board when I pull the trigger, but not at the plug that leads eventually to the brush bar.

I see, sorry.

Is the trigger dual contact? meaning does it close two seperate loops? sorry I’m looking at this completely blind bud with only your image to go off.

Is this actual battery voltage or just so happens to be a similar voltage? I’m guessing this is just voltage to the board though as I was under the impression the main motor was brushless (?)

I’d be surprised if the other motor in the brush section was also brushless though (but who knows, if I recall Dyson developed a 2-pole BLDC motor so perhaps they’re as cheap as a regular brushed nowadays) -

basically my thinking is the trigger switch simply switches the DC voltage from the battery to the mainboard, then subsequently the board converts/drives the BLDC motor. The secondary motor your having issues with would presmably not be so complicated if it’s your typical brushed DC hobby motor, can you take the measurment i asked for earlier across the terminals mentioned so I might get a better idea/confirm?

Any chance you can take some closer shots of the board? - might also be worth buzzing out where those two contacts are headed on the board which will likely take you to the troubled area

On further investigation it does just seem like the motor used in the brush section is just your standard DC brushed hobby motor and nothing fancy (1pcs Vacuum cleaner mattress removal mites suction head motor for V10 V11 parts 728243792932 | eBay)

MCU likely controls the power to the motor via a mosfet (maybe a dedicated motor control IC - though less likely) basically acting as switch . So I’d guess either the fet isn’t being told to turn on at it’s gate (or PWM’d depending) or something is wrong the fet itself. So as far as I can think, the only thing that could be at fault is, either the MCU isn’t telling the fet to turn on or there is a passive in series with the gate signal (such as a resitor) which is possibly faulty, the fet is faulty, or some other support circuitry such as a diode. (all assumptions regarding the mosfet mind you without further details about the board) or less likely something completely different such as having an isolated supply .

So I’d be checking the fet and making sure it’s not shorted out, then if not i’d check the gate voltage when the trigger is pulled (apparently the brush roller can be disabled with a button/from menu so i’d check that is enabled) and while trigger is pulled check the voltage at the fets gate and ensure it’s high (again all assumptions without further details on the board/ closer shots)

Hey, thanks so much for the info. I studied mechanical engineering at uni so, while I’m not dumb, electronics is not my forte.

This model doesn’t have an ability to disable the brush bar in the menu as far as I am aware. The only way to stop it is by jamming it and it always restarts when the jam is cleared.

Sorry for the asinine questing but, I have added a close up shot of the board to the shared photo link in the OP. I’m not really sure where the FET might be??

Thanks. And have a great weekend.

bit hard to tell as I can’t see the part markings (I think because they’ve put a mask/waterproof over top) but given the arrangement I’d guess the following is the mosfet in question,

no worries, neither camp is mine and I’d fail every exam :slight_smile:

I can give you a few things to test in the meantime.

I could really do with the part number on the presumed mosfet, so if you can, get some IPA and scrub off the coating and/or if it’s silicone based peel it off.

In the meantime I’ll base my assumption that this is an N-channel mosfet based on the circuit layout (it would ordinarily be easy to tell but Dyson are dicks and are using non standard wire colours) - I’m also basing the mosfet pinout on the circuit layout, surrounding components and logical reasoning.

So a few things that I need confirmation on - can you confirm that the line I’ve circled in black (drain/negative) is one of the contacts going to the motor in question and can you also confirm which of the two I’ve circled in red are going to the second contact going to the motor? (it may be both but it’s a bit hard to tell from your image)

You can check and see if the mosfet is shorted out by disconnecting the battery and checking in resistance from gate to drain and gate to source. If it is shorted ignore the rest of this post, if it’s not shorted out, continue on :smiley:

Next, I need you to disconnect the battery, and connect that motor and hose etc, then I need you to measure the now known positive and negative (the two contacts which go to the motor), with one probe on red and the other on black and let me know the resistance of the motor?

You can see in my image in violet pointing to a resistor, can you confirm this side of the resistor has continuity to the gate (highlighted in pink) and then following this let me know the resistance of this resistor also.

Next you can actually measure stuff live :slight_smile: . you can hook up the battery again and can check the highlighted gate pin voltage when the tigger is pulled and see if it’s high (I don’t know what this will be, maybe 3.3 or 5V in working scenario)

Next you can put one probe on the source side (marked in light blue)and your other probe on the positive (whichever of the two you determined goes to the contact - maybe both) and measure the voltage - this is motor voltage (prior to the mosfet switching) … I’ve got no clue what this will be, maybe 12V or 18V (?) somewhere in that neighborhood. I don’t think you’d have to have to pull the trigger to get the voltage here but it really depends, so if you don’t get anything try pulling the trigger and see if you then do.

Also it’s important to note, that the “ground” I’ve higlighted is not common ground so when your taking your measurments you need to be doing so with your black probe on an actual common ground (which you should be able to identify by buzzing out a few of those bypass caps for confirmation [disconnect battery before doing this]) or by using the highlighted source side of the fet (assuming this is indeed an n-channel fet)

Also, caution, I remember when opening the older Dyson that on the other side of that board is some monster caps, and I can see three spots on that board with through hole pins which would match the footprint for those caps - and they are quite beefy (hopefully you can see the three sections I’m talking about) so prior to working on the board after disconnecting the battery, make sure to measure the voltage on these caps, if they are high discharge them with a resistor or worst case with a screwdriver with a plastic handle so you don’t get zapped.

Hope that all makese sense and if not just let me know

Hello, I have the same problem and also came to the same conclusion that the problem probably is the mosfet. I had a bit of corrosion between the Current sense resistor och the mosfet. After cleaning it up a bit and putting a bit of new solder I could get the attachment brush to spin but it kept spinning for 5-10s after I let the trigger go. The mosfet also gets very warm, to warm. The biggest brus pulls about 30 watts according to the label, this will almost mediately take the mosfet to 100 degrees C. Checked with a thermal camera. If i use the small 10W brush it stays around 50 degrees C.
The markings on the mosfet are: 5811(top row), RL50(bottom row), tried googling on it but didn’t find much. Any idea of what kind of mosfet it is?

You are otherwise correct in that the drain is connected to the negative lead to the brush. The ones you circled in red are the main positive/negative from the battery.
Fully charged battery is 29,4V

What is the purpose of the pulldown resistor? (it is connected to the gate)

Hope you can help.

//Dennis

Hi

I reckon in either case this would be well beyond it’s normal operating temps (though the datasheets suggest this is still within safe limits… not as far as I’m concerned).

This was the first result for 5811

If you scroll down the datasheet to the “marking” section, it states the part is marked as “5811” so think it’s pretty reasonable to assume this is the part in question :slight_smile:

Regardless, just ensure your G, D, S all seem to line up etc and better yet you could opt for a mosfet with a higher rating too.

Just to stop the gate from floating I’d imagine.

I don’t see why any of these wouldn’t be suitable replacements if you can’t find that exact mosfet anymore

https://www.mouser.co.uk/c/semiconductors/discrete-semiconductors/transistors/mosfet/?id%20-%20continuous%20drain%20current=41%20A|~48%20A|~51%20A|~69%20A|~74%20A|~77%20A|~85%20A|~103%20A~~107%20A|~136%20A~~142%20A&package%20%2F%20case=WDFN-8&rds%20on%20-%20drain-source%20resistance=2.2%20mOhms|~2.4%20mOhms~~3.5%20mOhms|~4.8%20mOhms~~4.9%20mOhms|~5.6%20mOhms|~6%20mOhms~~6.1%20mOhms&transistor%20polarity=N-Channel&vds%20-%20drain-source%20breakdown%20voltage=40%20V&vgs%20th%20-%20gate-source%20threshold%20voltage=1.2%20V|~2%20V&rp=semiconductors%2Fdiscrete-semiconductors%2Ftransistors%2Fmosfet|~Id%20-%20Continuous%20Drain%20Current|~Rds%20On%20-%20Drain-Source%20Resistance|~Vgs%20th%20-%20Gate-Source%20Threshold%20Voltage

You can narrow it down further if you want :slight_smile:

Hi. Maybe some of you know which MOSFETs are used to drive the Dyson v11 main motor? There may be a link to a datasheet or shop to purchase.

Are you joking? re-read the topic if no :slight_smile:

photos.app.goo.gl/kRSwP6ULzVTYzpL27

Perhaps I’m blind, show me where these transistors were discussed here.

You said Mosfets… the motor mosfets have been identified and alternatives have also been suggested.

Perhaps your talking about something else?

I can’t open your link above, maybe imgur is a better bet :+1:

imgur. com/ a/ 0MNheQW

Maybe that is better (just delete spaces)

What’s the marking on them?

BLDC fets afaict

I can’t see the markings. These transistors are in poor condition, as due to overheating they have partially desoldered from the board. Because of this, heat was not removed from them and they burned. I’m writing here because I’ve seen some people have the same boards and perhaps you can see the markings on them

if you can narrow things down with your meter check the pinout with them removed, see if they’re nch / pch, provided that, and package type you’ll have a good few options :slight_smile: