Error 2002-2634 when inserting game

Hello,

I have another switch I’m kind of stuck on. The thing is practically brand new, but it appears to be an older hackable serial number. Everything on it works perfectly fine, but when inserting a game cart I received this error.

I replaced the game card reader with a known good working one and I still receive the same error. I can tell the switch was never opened and I doubt it was barely used. The red thermal paste doesn’t look like it ever got warm.

When looking up the code, a bunch of result come up about hacking it. It appears that the person that sold it to me tried hacking it and failed?

I checked components around the game card reader and found no issues. Any help would be greatly appreciated.

I thought about possibly installing hekate to see if I can get it to read games, but would rather keep it stock firmware.

Thanks!

Weird, you are right, searching for the error seems to suggest that it is caused by a miss match between the card slot and main firmwares. Though if that was the case i would expect swapping the board to fix it, or it to come up all the time when replacing them…
Still, have you tried updating the system?

Yeah, it’s got me stumped. Now that you mention it, I forgot to add that I factory reset it and upgraded it to the latest firmware. Still the same issue which makes me think it’s definitely a hardware problem. I don’t fully understand it, but from reading, there are fuses that get burned with each update to prevent downgrade attacks? I guess if the amount of blown fuses don’t match the firmware/cartridge reader this happens? I tried looking for fuses on the main PCB, but the only one I know if is the USB-C connector. I was randomly testing components in continuity in hopes of finding something open, but no luck.

I can’t include links so do a Google search to find this article on it.

hackernoon how the Nintendo switch prevents downgrades by irreparably blowing its own fuses

The fuses they talk about are in the CPU itself, and prevent downgrading. If the installed software is a lower version it wont boot at all. As you are able to get it to boot, it wont be an issue with the fuses.

I guess that makes sense why I couldn’t find them haha.

Everything points to using hekate to get it to bypass the fuse check, which is unfortunate. Since I have the latest firmware I’m not sure it will even work. I’ll keep messing around with it off and on in hopes of getting this fixed. If you or anyone has any ideas on how to get the cartridge to read on OFW, please throw a comment in and I’ll update this as well with progress.

Thanks

if you are sure it’s not a damaged pin/trace.

then I’d reflow/replace the anti piracy chip. (think it’s link to the CPU. not sure)

can you play digitally downloaded games.

Where is the piracy chip and is there a way to test it before reflowing it?

it’s the bigish bga chip above the power on zif.

I’d check if you can play digitally downloaded games first.

I’ve never had this has a fault, but it can cause games not to run. although I would check damaged connectors, traces first.