Error occurs when creating account in OFW (2162-0002)

Hello. In advance, I’m sorry for my poor English skills.

First of all, I have a modded OLED console.

It worked well when I first modding it, but I haven’t been able to use it since I updated the firmware and format it. The HOS firmware version is 16.0.3.

Now, let me explain the specific symptoms.

After booting to OFW, the setup screen appears normally, but even if I try to connect to Wi-Fi or just proceed without Wi-Fi, an error occurs in the process of creating an account.

The error codes are all the same, 2162-0002.

Once again, I’m telling you that this is a problem with “OFW”. I’m sure it’s definitely not a problem like custom themes.

The recognition of the Joy-Con in OFW is completely normal both wired and wireless.

I also performed a complete initialization through the recovery maintenance mode (pressing two buttons of volume together at boot time), but it has not been resolved.

When I looked a little bit, there were many problems with the M92T36 chip, so I used a multimeter to check if any diode was shorted, but I didn’t find any problems.

Most of all, what drives me crazy is that all other functions work normally except only for the setting process in OFW mentioned above.

It is charged normally, can make NAND backup on hekate, can check and dump of many other informations, and can extraction of key files through lockpick.

Even Android does everything perfectly. Of course, it’s charging very well, and everything works perfectly, including Joy-Con recognition and fully funtion, Internet connectivity (Wi-Fi), APK installation, Play Store, games, and video playback!

I thought I could see more detailed information through atmosphere, so when I created emuMMC and tried it, I got information that the error code is 2162-0002 same as above, but with additional information, the program 010000000000001E is causing an error.

I looked into it and found that the program with that number was “account-sysmodule”. Is this a problem with the nand’s sysmodule inside the system partition?

  • The attached image below is taken from the internet. So it’s not mine, but the error code and the program code that causes the problem are the same with mine. The difference is that my atmosphere version is 1.6.2.

imgur. com/a/1nNkanR

If anyone have any solutions, other presumptive causes, or anything else to check, please let me know. I’m sorry I wrote this out of frustration. Thank you.

After a few days of hard work, I am writing that I have succeeded in fixing this.

As I expected in the article, the problem with the sysmodule at the system partition was correct.

Following the “nsw unbrick guide level 1” of some other youtuber starting with the “s”, I replaced the HOS of sysnand with a file made from the “emmchaccgen” program, which made it work perfectly.

I think this is the first time I’ve seen a sysmodule that is a component of HOS being destroyed. There was no problem right after the update to version 16.0.3, but I think there was a problem after the initialization, so I think there was a problem during the initialization process, but I still have no idea why.

Anyway, I’ve now updated it to the latest version, 17.0.1, after which everything works fine even after further initialization. Thank you all so much. :smile: