Face Buttons/D-Pad not working even after flex replacement


I have a buddy who had a cup of iced tea spill on their PS5 controller. It was sticky/malfunctioning so I told them I could attempt to clean it with isopropyl and see if I could get it working again. When I did an initial test, the buttons seemed fine. I disassembled, cleaned, waited a few days before reassembling the controller. I put it back together and the face buttons/d-pad wouldn’t work. I assumed I had somehow damaged the flex cable. I replaced that just recently, the buttons still are not working.

I attempted to swap the motherboard into a midnight black dualsense casing/parts, the face buttons do not work. Once I put the black controller back together with it’s original parts, it functions again. I know they are different board revisions, but the flex cable connector looks the same/the replacement flex cable for the white dualsense is not functioning either.

This leads me to believe it’s a board problem, maybe a shorted trace or something, but I cannot figure out where to begin. I’m not sure where I should be testing/examining on the board.

Just wanted to reply since I think I fixed it. There was a little residue on the corner of the board, but that didn’t fix it after reassembly. After giving up for the night, I set the controller down and noticed one of the buttons activated. It looks like the casing was just ever so slightly warped and in the stock configuration the pads weren’t making full contact. After “bending/flexing” the controller body, I noticed it would activate. I think at some point, the controller must’ve been slightly warped and I will probably have to pout a small spacer behind the flex connector to ensure full contact 100% of the time.

Man I am having the same problem.I have tried 4 different flex replacements and so far only left on the dpad works. Occasionally I will catch it rumbling and clicking like a button is stuck. But I can’t find which one.vi would be interested in any updates

Update. I placed a small piece of sticky foam behind the flex cable where it contacts the motherboard. Problem solved. But now the r1 isn’t working…lol