Failed modchip install - no boot

Hi everyone.

I’ve acquired a Switch Lite, which a previous owner gave to some repair shop to modchip (picofly), but ended up receiving back a console that doesn’t turn on.

Tried powering it up - no power drain
Went through default checks - M92 and BQ have no shorts, 2R2 resistance is there. I’ve also un-jumped the pads that were soldered during chip installation

When I’ve checked the battery, it showed 2.5v, and as was suggested somewhere else I’ve tried jumpstarting it with 5v for a couple of minutes, which helped and brought back the voltage to around 3.6v after 2 minutes of charge, and the console started draining around 5w when connected through usb-c (my usb tester is on the way, I’ve checked it thoroughly by plugging and unplugging it from my laptop and checking it’s wattage drain), and after a couple of hours it charged to full 4.2v through usb-c, but still no boot, nothing

Started probing a little more, and found out that there are shorts on caps on MAX77812, but some other forum messages suggest that it’s okay.

Also I don’t know how relevant this check is on a Lite, but I’ve plugged into a PC running TegraRcmGUI and it showed “RCM O.K” (and recognized by PC as APX), which I believe suggests that the cpu is not fried?

Also nothing on the board seems to produce lots of heat, nothing sus there

At this point my search is too narrow to find anything that follows my symptoms, but if I’m wrong I’m more than happy if you even just throw a link at me and tell me to follow it and report

Little update: After leaving the switch unplugged for a day, battery dropped to 3.2v, so it’s obvious that it has to be replaced, I’ll do it in the nearest future.

Also was able to confirm that console enters fast charging, type-c voltage measurement shows 14.95v

Ok, I’m here with an update

I’ve replaced the battery, switch shows a draw of 15.04v and 0.52a when charging (same as before)

When taking pics of the board I’ve noticed shorted pads (between cpu+ram shield and a WiFi+bluetooth chip shield) that are normally not shorted, so took care of those and cleaned up the board a bit

And got some progress! Switch now draws 15v 0.73a, and when I try to turn it on it drops to 0.69a and remains there.

When taking those measurements the battery was about 3.6-3.8 volts charged

There is still no image and no response to any button presses, after replugging the charges the console goes back to drawing 0.73a.

BQ and M92 chips get warm, but I would assume that it’s ok since they are not burning and BQ even has a thermal pad to keep care of that

if your s-lite apx/rcm mode still got detected by PC, you should check the pads around this around this area. Take a clear picture and upload here.

Here ya go, hope they are good enough

pretty much all pads got broken or semi broken by some expert solder work. No wonder stuck in apx mode

fix those pads with jumper wire should make it back to normal IMO

1 Like

Seen that coming, thanks for confirmation! I’ll try that tomorrow

Done the soldering, it did not help :frowning:
Here’s the job:

Plugged in the old battery since the new one approached “charged” level. The draw is at 0.7a, drops to almost zero for a moment when trying to turn on and goes back. Connecting to PC does not show nor APX device nor RCM, though windows still does its chime when connecting and disconnecting (though it’s delayed)

So I’ve done more “pattern finding” work and found out that it’s really chaotic
It still does react to power button with some small amperage drop (avg 0.04a), but no sound on screen touches / button presses, even with connected headphones
I’m thinking of ordering the modchip that the previous owner tried to install, since it has an LED that at the very least could indicate some error (or even fix it? I’ve read some threads here where people were trying to fix someone switches memory because if I remember correctly the modchip modified it, so my thought is that it would boot into stock OS with installed chip)