Hakate not detecting battery

Hi all,

I have a switch here which hat auto rcm on it.
When I meassure the amps, I get 0.38a.
I can’t boot any firmware at all, no origninal fw no cfw.
So I jumped into hakate and saw, that the battery is not rcognized at all (see screenshot).

Battery is working fine with another switch. Also tested another battery… no change, so battery isn’t the problem.
I think I already changed the BQ24193 and the M92T36.
Howevery I ordered new ones and will do it again as I’m not quite sure as the switch was laying around several months.

Anything else I could change, or try?

Thank you =)

I would take a look at the fuel gauge ic (MAX17050) on the backside where the battery connector is. Maybe the ic has a defect or one of its lines is grounded.

Values are from diode mode measurements. Red probe on ground, black probe at the pads. Please only measure without any powersource (battery/powersupply) connected. The values differ from multimeter to multimeter. ‘0mV’ means a direct path to ground. ‘OL’ means no connection in diode mode to ground.

Thank you Calvin. :blush:

That IC was also my guess, I already changed it with one from another defect switch, which at least boots to the switch logo. I also ordered new MAX17050 ICs.
Do you have any tips on changing that IC? I have some simple reballing tools, but this IC is so small …
I guess I succesfully got the other MAX17050 in place by just swapping it with hot air,
but the new ICs might come clean without solder so would you try reballing it?

I measured the values.
On the green pads is get 0mV (ground)
The other values are similar, on my multimeter the volategs are about 10V smaller, but they are all in the same range so I think it’s fine.
So this would mean my swap was succesful?

The MAX ics I ordered had all solderballs underneath right out the tape blister.

I have not much experience in soldering BGAs. The few times I change a BGA succesfully I tried to remove most of the solder from the pads and tried to get the remaining solder evenly spread over the pads and then I placed the new ic on the pads, applied flux and soldered the ic with hot air.

In your case I would try to get nearly the same amount of solder on the pins and than place it on the pads.

Oh ok nice to hear, I hope mine come also with solderballs.
Ok I will try it like that :).

Changed the MAX17050 today, unfortunately no change … any other suggestion?
BQ24193 and the M92T36 are already changed

I removed the auto RCM now. It seems like the switch has bigger problems… when plugged in, I get 0 amps (actually sometime it show 0.02 amps for a split second, but most of the time 0 amps) and a black screen.
15V go up to the M92T36 (meassured at the cap very close to the IC).
Fuse seems ok, as I get 15V after it and on parts beeing connected to it like the M92T36.

What is shown on the ampmeter if you plug the Switch on the pc and start Hekate?

It shows 0.11 Amps and 5.13 Volt when I’m in Hekate menu

So there seem to be no connection to the battery. Did you check between the battery connector and the BAT pins at the bq for continuity?

Connections is fine, got continuity between the markings

BTW, are these diagrams with those values public available? I mean for the whole Switch motherboard.

Hi all. I have the same problem as Pahnda. No Shorts on capacitors near the charging ICs. Drawing 0.5A at 5V with the battery. The battery is actually charging as the battery voltage did rise to 4.1 ish after 30 minutes from 4.0.

Can boot to Hetake boot has the same screen as Pahnda. Keys and logs can be dumped to sd card

My guess is that the system is capable to boot as the nintendo logo does flash, but the software shut itselfs down due to some internal checks related to the Fuel Gauge.

Pahnda, sucks that you changed the MAX17050 Fuel Gauge and still not able to get it detect.

A thought just occur to me that if RCM payload works perfectly fine, maybe Ubuntu can be loaded. Going to put my switch back together and see if that’s the case.

In my experience a faulty fuel gauge (or one that doesn’t respond the the SOC) will prevent any form of boot. Black screen, no logos at all.

Double check for resistance through to the seated battery connector from the test points that Calvin indicated on his awesome diagrams. If the sense pin (middle) has resistance, or open circuit, then fuel gauge will read no battery and Switch will black screen before logos on boot.

The BQ not sensing the battery will result in the low current pull you are seeing, I’d suggest.