HDMI will not output after I connect the southbridge board to the main motherboard


I had an Xbox come in that another repair shop worked on where they tore up 11 pads off of the HDMI port. I repaired everything, got the HDMI port connected, and tested everything with a breakout board. Everything worked great! I reassembled it and was not getting any HDMI output. I tested again with the breakout board, and pin 14, which normally reads OL, read .8xxx. I took it all back apart and it read OL again. I then began reassembling the console one piece at a time, testing that pin each time, and only when I plugged in the top board with the board connection ribbon did it no longer read OL and it started reading .8xxx all over again. I tested 3 of the top boards and they all have the issue when I plug it into the bottom board via that ribbon. I have also used two ribbons and the issue persists across each of them. So that leads me to believe the issue is on the main board itself.

Any recommendation as to what I should be looking for? Never come across this issue in the past, so not sure where to look or what I am looking for.