Help diagnosing BSOD after Picofly install

Hello everyone! First post here!

So I’ll try to explain everything as best I can (OLED model):
Phase 1:

  • Installed Picofly with hwfly v2 flex cable and dat0 adapter (the bad ones).
    -Perfect glitch everytime, “no SD card screen” shows with no problem.
    -Try SD card with hekate as the payload, black screen. Lockpick same thing, in fact every payload gave a black screen, except one, UMS-Loader.
    -I’ve since learned UMS-Loader uses only APU iRAM, which would indicate APU is good, but since hekate won’t run that points to RAM or traces from APU to RAM.

Phase 2:

  • Removed everything modchip related. BSOD. To be clear, I had this BSOD whenever I tried running OFW from picofly.
    -I’ve tried presurized pcb cleaner under the rams (as much as I could), IPA bath, nothing.
    -Pressure either on the APU or RAM’s makes no difference, even in different places and pretty large amounts of pressure.

How should I proceed? What should I test? I can see no shorts around the MAX chip, which as far as I know kinda “regulates” power to the RAM?

Another thing is I noticed light scratching on the 3 traces by the clk point, next to the ground from where the shield was. The middle trace is exposed I believe, but it doesn’t look like it’s cutting the connection. I’ll link some pictures:https: //imgur. com/a/5Df8YQP

Sorry for the big read, I wanted to try and explain the problem as best as I could.

Best regards, and thanks for any help, really going crazy diagnosing this switch!

I ended up exposing the traces a bit forward, continuity in all so I assume those scratches I talked about, altought explaining perfectly the problem, are in fact not the problem.

I don’t have experience with Oled models, but I did get one in with that exact behaviour. They installed a picofly (no flexes, all wires/mosfet install). I woudl get a blue screen when booting anything from the sd, I would get a “no sd” screen when I ejected it, and when I disinstalled everything, just a blue screen.

After hours of inspection, it ended up being the gnd pad on top of the SoC, maybe the solder on it was shorting a line out that is very close to it, or something like that, becaus under a lense, I could not see anything wrong. I heated my soldering iron to very hot, applied flux and tinned the gnd pad again, and that got it to work.

So, I would say, look on top of the SoC, check all the capacitors, that none are shorted out, none of that diode mode, check actual resistance, as some of the capacitors are really low (about 10 ohms). If anything is dead short, check soldering, and if anything was soldered to the gnd spot (square pad on top of SoC) try to clean it really good, and re tin, as it was that gnd spot that did it for me. I’m still wondering exactly what was going on, as it is a gnd spot, and visually nothing was weird.

1 Like

I’m sorry, maybe because english isn’t my first language I didn’t quite understand that.

Do you mean that square pad I circled as 1?

Also should that triangle I marked as 2 be ground or just the mark of pin 1 for alignment?

Thank you so much for your reply!!

Yes, circle number 1. That was what caused my bsod, as odd as it might seem, it is just a gnd. But after adding a good thin coat of solder to it, the bsod went away.

The triangle I do not know anything about.

1 Like

I never got any solder there, now I’m wandering if I should tin it

Okay a LOT of pressure on the bottom ram module gave me static on the screen, as soon as I let go it went blue with artifacts.

Also, now the blue screen isn’t constant. Like more than half the times I try turning it on it just gives a black screen.

This is pretty much confirmation of a bad ram right?

No, if there was no movement there, then leave it.

I wouldn’t say confirmation, but it could be. But if the console was working fine before the installation, and right after the installation is whene it failed, the I highly doubt its a bad solder ball under the ram. It’s more like something to do with the mod done.

1 Like

That was my train of thought too. It had to be something I messed with. But I’ve checked and double checked everything. Also, I remember some time ago reading about someone that had a theory the hwfly flex cable had somehow fried his ram (don’t remember the specifics but he detailed it).

I had also a suggestion that a tiny piece of solder or even the flux I use could be causing trouble with the ram.

At this point I see no other alternative than trying to reflow that module, at least with my current knowledge. No way to determine ram for sure, APU seems good since it runs the payload I mentioned, traces to ram are a bit dodgy but I tested for continuity and had no problem. No other payloads running also indicates something to do with the ram.

I really don’t know, I still have a bit of time before my new hot air station arrives so I’ll try some more investigating, but I don’t even know what to try anymore.

Maybe you just damaged the SoC/Ram joints when ripping off the SoC/Ram shield frame? I’d be reballing instead of reflowing if it were me incase of pad damage below.

I’m gonna guess that it was something else you did, coincidence or you also have joint related issues below and the heat you applied relieved and resolved the issue and if the latter I wouldn’t get your hopes up that it will last :frowning:

1 Like

At first I thought the same. This was my process after checking other things like scratches and bad joints.
First I measured all the caps on top of the SoC, found no dead shorts, but proceded to clean the two used with alcohol and re tin the two caps where the wire was soldered, Turned it on, still blue screen.
Then when looking at the gnd spot it looked really bad, as in black and the solder was jagged, so I cleaned with alochol and tried to smooth out the solder, plugged it it, and it booted. I though it had to be the application of heat, and it must be a bad solder ball (not knowing where this console came form or any history). But the “smoothing” I did to the solder on the gnd point didn’t come out that nice, since I didn’t use enough heat, so I redid it, tried to boot, and blue screen again.
Then I thought okay, definetly the heat, so I applied a good amount of pressure, turned it on, and still Blue screen.
I then applied a tiny bit of flux to the gnd point, got my iron heated even higher to make sure the solder flows right, applied a blob of solder quickly and that was it. It no longer looked black or jagged, a thin coat of applied solder, and the console booted.
This was a couple of months ago, when the picofly started coming to attention here, and it has not returned.
I am still thinking of what it could have been, I’m guessing maybe they scraped right next to it and there is a line there, and the jagged solder was creating a short from gnd to this line they scraped. I know it can’t be just the gnd by itself, there has to be something there.

These wafers are effectively just PCB’s at the end of the day so I suppose it’s possible this ground pad offshoots to other I/O and/or is a via, so I suppose if they had messed with it prior and if it had disconnected (Lines/via) then your soldering could have inadvertantly solved it… perhaps this is a “Star ground” point for layer/s

I’ll maybe sand one back on a wrecked SoC at some point and see what’s going on here :slight_smile:

Maybe, like I said I did scrape some traces but they seem to be alright.

I just find it strange it being the bottom module, since I cut the shield on top, it would make more sense to screw up the top module I guess?

Anyways, probably going to reball so I can see underneath and look for torn traces like you said, already have a stencil on the way.

I have a switch lite with the exact issue due to a picofly install. I was thinking it was due to a corrupt eMMC as I used the bad version of the 2.73 firmware. Will check out the caps and ground points on the soc. Hope we can figure it out.

Did the issue got fixed after reballing?

did you resolve this issue?