Help Needed for Console Screen Repair

I was attempting to repair a switch that had lost its signal connection to the TV, but the device was still capable of charging. I began by removing the back plate to check for any obvious issues but saw none. Then, I tried docking it to see if it was actually failing to connect to the TV. I don’t recall exactly, but I think I either heard a spark or some sound coming from the console. I suspect it might’ve been the ribbon cables or the Wi-Fi antenna cables causing a short. But then, when I tried to restart the console, the switch started crashing, displaying error code 2134-0501 everytime i rebooted it. Soon after I Noticed some damage to the USB-C port, I decided to replace it. Additionally, based on tutorial videos, I suspected the M92T36 chip might be the cause of both the error code and the docking issue, so I chose to replace that too.

Despite not finding any shorts on the M92T36 chip or in its surrounding area, I proceeded with the replacements as a precaution. After completing both tasks, I powered on the console. It booted up, but the screen remained blank, even though the backlight was on. The console seemed to be on by sound, and it appeared that the crash error was resolved. Unfortunately, I didn’t have an appropriate amp reader to check its performance to check if it could charge after the replacement; my only tool was a portable battery’s amp reader. A functioning switch typically measures 5V at 1.3 amps (With my portable batter’s reader) when turned on, but my switch showed a reading of 0 amps.

Then I tried to see if it would dock despite the black screen, I soon after i attempted it, the dock’s light started blinking rapidly upon insertion. Could it be that there might be a bridge in the USB-C port? I also checked the 0-ohm resistor in front of the USB-C port with my multimeter set to AC voltage, and it read 10. I thoroughly inspected for shorts at common points like the BQ charging IC, the M92T36 chip, and the P13 chip but found none.

At this point, I’m running out of troubleshooting options and am seeking guidance for further steps to at least get the screen functioning. I’ve also confirmed that the display connector is in perfect condition. Below are several pictures of my setup; perhaps you can spot something I’ve missed. Any help would be greatly appreciated. Thank you.

Here are some images if needed, if you need any pics of anything, Please let me know! Thank you!
imgur . com/a/yAD2sSx

  1. The latch of the display connector is molten. Could this cause bad contacting from the display ribbon?

  2. I would check in diode mode at the testpoints around the usb c port if the values are in the same range as shown in the pics and if they are not shorted against each other.

Thank you calvin! this really helped, from what i saw, there were no bridges. But now I’m having another issue, i think i discovered the issue on why my display wasn’t working. These resistors were missing. Problem is that when i grabbed my donor board and replaced the resistors in and turned on the console. Nothing happened. The console never booted, so i removed them again and it booted with the same issue as before. No display. So now I’m just confused on why fixing the console didn’t work.

There were no bridges, i made sure of that so now I’m just wondering why did these not work? These were grabbed from a fully functioning switch i doubt its the resistors but what else could it be?

imgur . com/TcWXK9B

Started poking around and found these to be reading nothing. Not shorted or anything, just don’t giving a reading. Is it the Display IC? do i need to replace that too?
imgur. com/Plju86X

Is the reading oL or GND?
If GND it could be the little diode. (orange marking) (RSX101VA-30)

The missing resistors are important for the display ic.

From left to right in line they should measured aprox: 74 kOhm, 13 kOhm, 23 kOhm, cap (0.1 µF/10V), 100 kOhm.

No, its reading 0ohm, not ground.