How can I check if it is done correctly? max 77621awei

Hey Guys.

I am in problem.
I thnik there is another problem after I brought the broken switch and tried to repair it.

when i brought the broken switch (Erista V1)

  • 1st nintendo logo and black screen.
  • 5volt… 0.43A charged. (fast charging also good)
  • it can boot to hekate. (by Rcm dongle)
  • it can’t boot to andorid.

I tried to change max 77621awei IC. there was 2 shorts cap.
I mistake it for short because it was 48 ohm.

I changed max77621

after the changing max77621

- only black screen
– 5volt… 0.43A charged. (fast charging also good)

  • it can boot to hekate. (by Rcm dongle)
  • it can’t boot to andorid.

I thought it was a problem due to the wrong work, So I tried it several times, but it was the same.

how can I check if it is done correctly?

The IC you’ve removed is the CPU regulator, Android won’t boot without CPU so unfortunately in this case you needlessly removed a perfectly fine IC :frowning: For future reference, if you don’t know what your removing or the purpose of a particular IC then you don’t have any business touching/reworking it :slight_smile:

How are you reballing this IC? you’ll need stencils and solder paste, you can’t just tin the IC/board with your iron and hope for the best. :crossed_fingers: the rest of the board is still ok

I think you may chang anther max77621,on the left of cpu.Stuck in the first LOGO is usually associated with that max77621

thank you for your reply.

I used new chip.

I compared normal to broken.

Broken switch:

Normal switch:

PMIC IC info is different.

Why changed Ic info(broken switch) is V0 ?

Ok, the reason I brought it up is because the chip you’ve put on is wonky, this can be down to what I mentioned above but also as a result of not properly wicking the pads prior to IC install/reflow or because of overly agressive wicking which results in over exposure of the pads which can skew the IC during reflow… if you can confirm?

Where did you get the IC from? a legit EU/US supplier or from China?

My best guess is this is an install and or chip issue as that’s when the symptoms changed.

I don’t think this is anything to be concerned about, I’d guess it’s just denoting a version/revision of the IC, if it’s producing your primary rails then it’s likely fine :slight_smile:

I got the new chip from china.

I tried 5 times with a new chip.

I don’t think there’s a problem with my work process because i’ve worked on a lot of similar things before.

Is there a way to make sure that the chip is installed properly while it’s installed?

I thought so, the chips reball looks poor and I can see minor damage on the chip itself (likely indicating these are recycled and reballed IC’s… which is pretty common)

Well there is, sorry :slight_smile: the chip is/was wonky which can be due to any of the reasons I mentioned earlier, while in some cases this won’t cause issues it does in this case throw in an element of doubt.

Not really, you can measure the resistance to ground on the VIN (SYS) and also the resistance to ground on the primary output CPU rail (inductor/s) and see how it compares to a known good. The other way (which you can’t do) is checking the voltage on the CPU rail output while booting L4T Ubuntu/Android.

It might also be your unlucky, and the SoC was the original issue (maybe joint related or just age), your rework nearby could have just changed something (assuming your IC and install/s have been fine) or just too much heat in the area which seems somewhat likely given I can see quite a bit of abuse heat wise to the caps and speaker connecter etc