Is it the charging IC?


New here. I got a Nintendo Switch that worked fine. And then went unused for about two weeks. Just sat in the dock.
And somewhere under those two weeks it died.

Tried resetting it, without succes.

Tried changing the battery, also did not work.

Got a USB tester to see if it took any charge.

And it showed: 15,21V, 0,492A and 7,485W

And when I removed the battery it showed:
15,33V, 0,60A and 0,912W

(Tried adding pictures. But came up an error when trying to post)

Thanks in advanced

I uploaded the pictures to my dropbox.

ht tps ://w w w. dropbox. com/scl/fo/c32hs62qxx5maontvg0dr/h?rlkey=ct3ccugk9ggkjvb4dycy0n2ek&dl=0

More like emmc issue to me, charging ic working fine from the amp meter measuring.
Try replug the emmc module to see if anything change

Hi and thanks for the reply.

I tried unplugging the emmc and connect it again.
Sadly it is still unresponsive.

Some more readings as i cant post pictures.

V-: 0V QC2.0
D+: 3,11 V
D-: 3,11 V
V+: 15,2 V
0,48 A
7,43 W
21,92 Wh
31,2 Ohm

Then it also says 01448mAh

So tried removing the battery again.

The info i got now is:

V-: 0V QC2.0
D+: 3,12V
D-: 3,11V
V+: 15,3V
256,9 Ohm

And also here the mAh: 00003mAh.

Not sure what the mAh shows :thinking:

Sorry for the spamming.

But after charging the switch. The battery doesn’t heat up. It is as cold as when not charging.

That dont feel normal does it (?)