Joycon not connecting

Hello Ladies and Gentledudes!

Sorry for possible grammar mistakes, English is not my first language.

I got a broken switch from ebay that seemed to be an easy fix but unfortunately i was wrong…
After changing the battery the switch booted fine but the right joycon does not connect (not even charing).
I cant connect them (tried two joycons, one of them brand new) wireless because the switch got a factory reset before selling.

Port and Motherboard looking perfect, i have no clue what can cause this. I can Post Pictures if you want to.

Greetings from Germany and thanks in advance.

I have now checked some caps and nothing is shorting so far. Got a new joycon rail in the mail today but the right joycon still doesn’t connect or gets charged… I really don’t have any clue how to fix this

First question, is it both that do not connect or just one of them?

If the other one is able to connect fine, it most likely something in the area around the joycon connector.

I would start by making sure that the connector looks fine and that none of the pins have come loose.
Next I would attach a joycon (or just a spare rail if you have one) and check continuity all the way through from the board to the joycon.

If all of this checks out, then we move on to diode / resistance readings at the connector pins to see if something has failed.

Thanks for your reply.

Checked the pins, all of them are connected properly and continuity tested good as well.

Where should I test for resistance/diode and what are normal readings? Found no values online.

Edited to post pictures, maybe you can see a problem

There is a thread on here somewhere that covers the readings around that connector but I can’t find it anywhere. If you get a diode and resistance readings to ground, in both polarities, and for all of the pins I will compare them against some boards I have here when I get a chance.

Sorry for the delay, i had some minutes free to take the measurements.

These are my readings (red probe on ground (usb port) and black on the pad, no battery or charger. hope this was the right way to do it):

Cool, I will try and compare with mine tomorrow.

1 Like

pin 1 : Gnd
pin 2 : Gnd
pin 3 : Gnd
pin 4 : MOhms - rises to OL
pin 5 : 100k
pin 6 : 52k
pin 7 : Gnd
pin 8 : Gnd
pin 9 : 10k
pin 10 : OL
pin 11 : 16k, rises to 60k

So, resistance wise, pin 5 seems the most different, which isnt great news, as it connects to the SOC.
Pin 6, which is also off also connects to the SOC.

I haven’t checked Diode mode, will do that later.

oh, thats really bad…
thanks for your help so far

I will redo the ohms test with my second multimeter later… i hope my multimeter is just trash

do you know what i can do if the SOC is bad?

It might also be worth measuring the left side as a comparison. As for what can be done if it is the SoC… no idea to be honest.

Pin 5 does also have a another route that heads off through a resistor, so that may be worth investigating also.

Measuring that resistor in circuit here gives me 100k, the one right next to it apears to be 0 ohm.

Continuity map, might help :man_shrugging:

Thanks! I knew it existed, but couldn’t find it :smiley:

1 Like