Ksger T12 V3.1 Station

So, having a nightmare with my Ksger T12.
Been trying and buying stuff but don’t seem to be getting progress.
So I bought a T12 from banggood, got 3 tips with it, K KU C4. All good calibrated the tips and tried it fine.
So bought some smaller tips from ebay JL02, C8 and a few others, I just can’t get them to calibrate. When I set the station to 400°c and check the temp with both my rst-191 and thermocouple with my multimeter, and they only show 300°c ish. So tried calibrating and they just fail. So bought some more tips thinking they might be dodgy from ebay, but still the same. So bought a new handle thinking it might be that was the issue. But still the same :sob:.
So bought two tips from the official Ksger Store on AliExpress, but still the same, contacted and they have been very hopeful. Contacted banggood and got nothing from them. So bought the latest v3.1 from the Ali store incase the banggood one was faulty somehow.
Got that this morning but still the same :sob::sob: still having issues getting things to calibrate, with the new handle (green carbon fibre one) and the image one.
Thought I would see if anyone has tips/suggestions before they go in scrap bin and I cry over the lost ££££.
(I have contacted the AliExpress store but waiting for reply)
Got two xbox one s to play with that’s been sat in the dinning room for 3 months :grimacing:

Heya man,

What do you mean they just fail after calibration? as in they aren’t maintaining the calibrated temp or they are just not getting up to temperature at all?

or is it displaying error on the screen after turning on with a tip connected?

Or is it your calibrating them but afterwards they’re still 100C negative to what your actually measuring with an ext TC?

Yeah so when I switch on with the tip in, set the station to 400 and measure the temp my multimeter is only showing it at 300ish. So I run the calibration.
First one should be 428, but actual is 330. So set that.
Next step is 320 or something but reading is low so set what the multimeter says.
Last one should be 228 ish but again when I set it to what my multimeter says. As soon as I press the knob in just says cal failed

Then yes if I set to 400 they are still at 300 ish

Hmm that’s really strange, I’ve never seen this error on mine, but I’m on a lower FW version so perhaps there is a bug, or maybe the temp cal is too far out of range for it to do.

Whats the resistance of the element on these tips your having troubles with?

What happens if you don’t adjust the temperature readings during calibration and just keep defaults and just keep hitting the knob, does it throw the same error?

Will try later today. Will try a few other tips as well and document everything as I’m confused what I’ve tried and tested :grin::dizzy_face:

Thanks for the help btw

So got the multimeter out and check some test resistors first.

So looks like I’m getting about 8.8 ohms.

That was the same for the 4 tips I checked.
2 from the official store and 2 that I got with the original station that seems to be OK and calibrate fine.

So approx 8 ohm is a normal reading for all, the TC is in series with the element, so doesn’t seem like that’s your issue.

What’s the results of just hitting enter with the default temp values during calibration, does it still throw that error?

Do the new tips which are causing issues throw an error on the display at all? I’ve noticed, that for whatever reason that some new tips will sometimes throw an error message intermittently on the normal display for a while until they’re broken in… no idea what causes this.

temperature will range from room temp, error, to max set temp, then after a while it will start reporting the actual temp… or rather, what it thinks is the actual temp, until calibration.

Yes the new tips did the error while heating up on first go. But let them hit 400 (or what it thought is 400) switch the unit off waiting for it to cool naturally. Repeating and few times and now they just go from 150 stand-by to 400.
I did also see about them “settling down” after a bit, but some of the other tips I got from ebay I’ve tried all this about 4 times :grin::grin:

I’ll try the pressing in default values tomorrow, I’ve put the station away, my solder desk is also my job bench and needed to reboot some servers :grin:

When you say just default do you mean start the calibration click on the first, wait for the show temp to get to set, click and do the same for the 3rd?
I’ll have a good play tomorrow afternoon and write it all down.

When you start the calibration, it will show set and actual temp, just hit the knob with whatever the value is the “default” don’t adjust, and just keep doing that until you reach the end, if it throws an error again it would indicate this is not a software bug/error… at least if it doesn’t do this with your known good tips

OK thanks, will give this a go tomorrow afternoon with the Kown good ones. The ones I got with the new station some ebay tips and the j02 and c08 (couldn’t see this in the tip menu) I bought from the Ali shop.
Thanks for the help so far

Ready to give up now :cry: each time I try a tip I get a different issue. Even if I go back to a tip I ready tried.
I’m wondering if its how I’m measuring the temps.

What and how should I be measuring/calibrate the tips?

I’m using this at the moment (ordered some new sensors to try Wednesday if they come)

So you just put the tip in the center of that tri-way thermocouple of you FG-100, with a bit of solder on the tip to improve contact.

It will give a readout, and you just plug that readout into the KSGER station during calibration and just clean, rinse, repeat until you reach the end.

Does it still throw that “cal failed” error or is it something else?

As I’m now wondering if this is a contact issue or possibly a wiring issue in the handle or connector itself.

I’ll wait for the new sensors to come before trying again.

Yeah a few when I tried they were such low temp after the 3rd setting it would fail. These were mainly the smaller tips J02 JL02 C08 C1 etc.
The larger ones I got them though the calibration, and seen OK when I check straight after. But when i change the tips a few time for different ones and go back to that one it seems out again.

Once I get the new sensors I’ll try a few of them again. See what happens

Well the station itself doesn’t care how big or small the tips are, it only cares about the elment/TC, so if it “sees” the 8 ohm element/TC you’ll get heat at the tips, if they all measure approx 8 ohm then, the temp at the tip is going to be very approximately the same, of course this could still == 100C variation between tips until after calibration but they should all get hot.

I use the aluminium handle variant and it uses a very different prong style within, which imo is much higher quality than the other versions, so I would be checking the voltage on the points of the tip directly (+ and -) while it’s slid into the PCB/prong adapter and seeing that you measure a consistent voltage.

I’d check the thermistor also, (10K i think) on the handles board, might also be worth switching that to the “CPU” NTC in the menu and if it resolves the problem then you can blame that.

I doubt this is your problem, theyr’e just a thermocouple, nothing special, your MM K-type likely agrees with it right?

Where did you get the handle from? I tried getting one from banggood but never showed :thinking:.
Yeah my MM was more or less the same but having issues holding it to the tip enough and stedy. Just found the sensor easier.

I’ll check the thermistor and change to CPU.

When checking the voltage, is that when the tip is powered and standby/sleep/or at a temp.

Thanks for all the info and help so far. Wish this was a PC/Network I’d be in my element :grin::grin:

So check the handle.

Get 10K when i measure just the handle. Then 4.4K ish when it’s plugged into the station.

Link to a video of the voltage.
Basics when the tip is heating up the volts are steady, when at temp it jumps about but i guess that’s to keep it at that temp.
Again when cooling down there’s no voltage as expected.

I’ve been reading up on this subject for the past few days as I am working on something unrelated in regards to my own KSGER station.

I’ve seen several posts elsewhere detailing that “cal error” you saw is a software related bug on certain higher FW versions, hence why I don’t see it.

It might be worth contacting KSGER and asking if they will provide you the FW binary file so you can roll back the FW to a version which doesn’t have these bugs, using an ST Link

Alternatively there is an open source FW for these stations here,

ref here

Thanks for all the help on this, yeah was looking at that the other day wondering if I should try it.

Might just order a St link thingy and give it a try