Laser not moving in carriage

Hello all. I recently acquired a CUH-1215A for a very good price. The only issue was (notes from the owner) that it would not read discs. I dismantled the console and cleaned it thoroughly. I found that a Pokémon card had been inserted into the drive. Believing this was the issue I removed the card and reassembled. I applied (exact right amount) new thermal paste. Checked all cables and tried her out. No joy. The console works perfectly fine (even quietly) except for not reading discs. I replaced the laser carriage with a new carriage and new laser. I replaced the ribbon cables to the disc drive. I left it open after the install of a second new laser and found that the actual laser diode was working properly and the disc would spin up. The issue I found was that the laser was not traveling inside the carriage. I installed the old carriage back into the console and same results. I check the connectors on the MB and all seemed fine. Any suggestions? Thanks a million for any input.

Do any of the three switches in the disc drive control the movement of the laser?

I’ve got exactly the same problem, though mine is a 1216A. Disc is spinning, laser itself is working, but not moving. Tried 3 different carriages. Did you have any luck solving the problem?

No I never got any farther however two days ago I received a control chip for the disc drive and if I can get to it today I’m going to replace it and see if that’s the culprit.