Left joycon connects no charge no input

Little background on this to get on the same page. I was given a switch to repair that had a destroyed SD connector and a ripped fan FPC connector. Along with the fan connector i noticed a resistor and cap had also been ripped off the board right behind it (in between the fan and lcd connectors). After replacing the fan and sd connectors, I hooked everything back up and noticed that while I do get the noise and visual notification that a joy con connected, the system does not recognize it as being attached. Going in the controllers menu also shows the left hand joy con missing and not charging, however I am able to connect it via BT and it does work just fine that way. Right side joy con connects and shows charging just fine. So i went through as many threads as I could find with similar issues and here is what i’ve tried so far:

  1. This revision is one that doesnt have the diode behind the fan FPC.

  2. I replaced the resistor with a 1k 0201 and the cap with a 100nf 0201. I guessed on the cap value, and I didn’t have a 2kohm resistor available (my one donor is liquid damaged in this area and that particular resistor is looking not healthy, but thats how i got the 2kohm reading) and thought the 1kohm would be close enough. Regardless, with or without these passives I get the same behavior.

  3. the fan functions as I would expect it to, ive watched it come on and off and did not notice any odd behavior

  4. I replaced the “PU” IC located on the backside of the board for the left hand joycon

  5. I’ve tried multiple, known working rails and joy cons

  6. added fresh solder to the joy con fpc connector as the back portion seemed poorly done from factory (legs were loose, although still making a connection judging from my meter)

  7. Cleaned out the connector with 99% IPA and compressed air / toothbrush

  8. compared diode and resistance readings (all came with in tolerance levels imo, but were around .002 different between boards)

Other than this joycon issue the switch is 100% fully functional afaict. No noticeable shorts around all the common areas. It is an unpatched system, i have not done an update on it as its not mine and don’t want to mess with the software unless I need to. Still waiting to hear back from this person to see if they don’t mind i try this. I know this person desires to use this unit for CFW stuff so I don’t want to mess any of that up or potentially ban his system.

I’m at a bit of a loss here after exhausting all my own known working avenues. Definitely open to any ideas or suggestions. I can provide any reading or photo if that will help diagnose as well. I’m well within my right to just button it up and hand it back as its outside the scope of what I was supposed to repair, but id like to solve it if possible I’m just at a loss as to where to go now.


Don’t know why I didn’t try this before begging for help, but, after placing pressure on the FPC connector (while it was powered on and on the home screen) I noticed it made a connection and the joycon showed as attached and charging. I replicated the behavior a few times as unslotting and reslotting the joycon would reproduce the problem, but then placing pressure on the connector would solve it.

I replaced the FPC connector with one from my only donor board and now the joycon shows attached and charging with no issue. So if anyone else out there is experiencing these symptoms, try my solution and see if it helps.

Sheesh, i feel dumb now but at least the console is completely working and I can give it back.