Left Joycon permanently rumbling & not working properly

Hello Guys,

this is the first time I’m using such a forum and I’m not really into modding/repairing. So today I got a new pair of joycon shells and wanted to replace it with my old ones. It all worked fine (so I thought) until I was finished and realized that the left joycon is acting very weirdly. So here are the symptoms:

  • When i press a button either no LED, or only the 2nd or the 2nd and the 4th are blinking
    this also depends on where i push my joycon physically
  • When i push it (often the bottom half) it also starts vibrating permanently until I press any button (I
    can also hold the button and therefore it is not vibrating)
  • But the LED is not blinking and it is not really recognized in the System even though the buttons
    work. For example if I disable vibration while the joycon is “connected”, it still vibrates. The connection
    seems very buggy (it doesn’t matter, whether it is in handheld or wireless)

I haven’t tried much since I don’t want to make it worse, but I don’t know what to do. While performing the shell swap I didn’t detach any ribbon cable, so I don’t think that’s the issue. Maybe cleaning it with alcohol would help?

Thanks for everyone helping!

So i cleaned the boards a bit and reconnect a seemingly lose ribbon cable and at least everything is working fine except of the LEDs, the SL button (it works but it does make a screenshot as well), the SY Button and SR. So i checked the ribbon cable going off of it again and notice a severe bend. Since I think that’s most likely the issue, I ordered a new one and going to replace it as soon at it arrives and then tell you whether it worked.