Low VDD_CPU_1V0, Error 2134-0501

Hi, I have a switch that had a physically broken charge port, and when I put a good battery in it it powered on to error 2134-0501. I replaced the port and still get the same error, I checked around MAX77620 and saw VDD_CPU_1V0 was only around 0.6V. The capacitor on that line has low resistance to gnd and measures 0.007 in diode mode vs the 0.07 I read it’s supposed to be. Is it safe to assume MAX77620 needs to be replaced or is it likely to be something further wrong. Unfortunately I can’t try a new max77620 since I don’t have any at the moment and this person is taking their switch back by the end of the night.

alright they were OK with me keeping it longer so I’m ordering and going to try a new max77620.

Stop using diode mode (for good :stuck_out_tongue: ) What is the resistance to ground here?

Not just yet as it’s booting it means it’s doing it’s job

Is in the realms of a normal reading for this rail but I’ll wait for your resistance readings :+1:

Infact while your at it you may as well give me all rail readings off the surrounding inductors of the PMIC too

Check this thread for your error, you’ll prbably find it’s something similar

I’m headed home for the night so most of that will have to wait til tomorrow but I do know the resistance to ground on vdd_cpu_1v0 was around 30 ohm, I removed the capacitor and the resistance to gnd went down to like 0 ohm.

Perfectly fine

Youv’e caused this while removing the cap :frowning: less speed more haste :wink: hopefully just solder smear on the caps pads and not something more serious

Hi sorry for the wait been really busy today. I measured all the rest of the rails voltages and resistance to ground. I was wrong about the vdd cpu it was actually like 17 ohm and i misremembered. Also it only went down to 0 ohm when I had the capacitor off, as soon as I put it back on it went back to the same 17 idk how that happens.
Anyway here’s the rest of the measurements I took I just put them onto a image

Did you try replace M92T36. ERROR code 21xx is more like a m92t related issue.
I found only 2 place resistance has slight more different than yours around the MAX77620H.

FYI. I have no clue what cap you been saying removing and the resistance goes to 0 ohm.

Is this a Mariko revision?

It’s because I think your only giving half the story, from the image (if it’s yours) you’ve reflown/messed with the PMIC and caused this issue it seems like. If no, then you’ve inadvertantly reflown the PMIC… taking the cap off and putting it back on would not alter the rails resistance to ground in the manner you’ve described (simply impossible), but if you’ve knocked the PMIC out of alignment and then came back and reflown again then that could alter rail resistance to ground…

If it’s an original revision, then 30ohm would be right on your boot CPU rail, if it’s a Mariko rev then 17 ohm would be about right. but the drop to 0 ohm is almost certainly as a result of your work I’m afraid. As a sidenote, make sure you maintain a consistent probe polarity when measuring resitance to ground - ie: black probe on ground and red at point of interest, switching will provide significantly different readings.

Your issue is as per the forum thread I linked to earlier (and as Jkyojo has reiterated) likely an M92 IC issue (which is consistent with your original USB port damage) and possibly joycon rail liquid/corrosion on the pin contacts (so this is definately worth popping the “dowel” pin out and checking too)

afaict, you have limited experience working on Switch, you’ve followed some dodgy repair wiki or guide and targeted the wrong IC, caused a secondary issue, so best I can say is you’ve possibly now got PMIC issues as a result :crossed_fingers: nothing has been damaged as a result :slight_smile: In future, avoid these repair wiki’s/guides and hopefully if you can’t fix the board in time for your customer you’ll do the right thing and replace the board for them :+1:

Also, hopefully it goes without saying, do not plug the battery or USB in etc until you have identified the fault otherwise irreparable damge could occur

it’s the capacitor on VDD_CPU_1V0, the one I labeled. Maybe I am just dumb and messed something up while removing the capacitor to check if it was bad because the resistance seemed low to me and then I un-messed-up it when I put the cap back on.

100% correct about that when I run into stuff I haven’t dealt with I usually just look at repair.wiki I never even thought to try replacing M92T36 since usually I’ve only ever really seen that fix error 2101-0001 and didn’t want to replace random chips if I didn’t have to. wiki said “Check voltages around MAX77620” for Error Code 2134-0501 so that was the first place I figured I’d check. I’m still fairly new to switch repair and board repair as a whole and it doesn’t help that I basically had to teach myself everything since I’ve got nobody irl who knows how to do any of it.

I haven’t intentionally reflown or done anything with the PMIC yet. I’ll replace M92 later and see where that gets me.

The serial starts with XKW so most likely but I’ll double check later.

1 Like

Yes, it’s Mariko for sure and even 17ohm gives a hint alraedy LOL

1 Like

Given the amount of flux (and it’s pattern) it does suggest you’ve [inadvertantly] reflown the PMIC (this could be the original flux under this IC which is often liberal and/or the flux you added while removing the cap) - 17 ohms is good for Mariko so hopefully all that happened was you dislodge PMIC, cause a bridge on your boot CPU rail and indavertantly put it right when putting the cap back down - hopefully there is no other issues cause as result :slight_smile:

Hey I understand :slight_smile: trouble with the repair wikis is they can’t account for all situations and a lot of the info is just plain wrong (Switch one in particular) and when you can take a “shortcut” you miss out on figuring out stuff for yourself, almost a right of passage :wink: I mean I’m just looking at the naming convention for the rails which i assume you’ve got from there (?) which would have you believe almost every rail from the PMIC is for the “CPU” which they simply aren’t and is misleading, and then other rail names which conflict with other rails/IO on the Switch board… last time I looked I’d estimate at least 50% of the info for Switch on the wiki was outright wrong or misguided and another chunk just seem like outright guesses :frowning:

That’s how most of use learnt mate, don’t worry about it :slight_smile: learn by doing, failing, doing again :smiley:

@jkyoho Hey bud, do you remember if Mariko has the diode present on SYS back at the BQ? I can’t remember (just asking because of the resistance OP provided on this rail)

1 Like

Not present, at least not on HAD-CPU-01 by my hand. I do remember maybe newer variant i.e HAD-CPU-10 or something has the diode.

1 Like


Yeah that’s what I was thinking too

1 Like