M92T36 replaced still short on VCONN_IN

Hi,

I bought a defektiv Switch and found that the cap above M92T36 for the VCONN_IN pin (pin 36) indicates a short in the line. I replaced the M92T36 and checked the amperage. It was ok. (~0.45 and than ~1.40)
I reassamble everything and got an error 2101-0001. So I took it a part again and checked the new M92T36 again and the pin VCONN_IN shows again a short. I desolder the new M92T36 and checked that the short is gone and it was gone. To be sure it s not the M92T36 I took a second new M92T36 and soldered it back… the short was back again. Desoldered it again the short is gone.

Any good ideas what I m missing?

Hi Calvin, Im not a pro when it comes to Nintendo Switch, but did you try to replace the cap that was showing the short from the beginning?

Vconn has a maximum input voltage of 6V
There should be somewhere a dcdc converter that brings the usbc voltage down

Check voltage of vconn_in without M92T36

Now I m total confused…

I reassamble the Switch and powered it on. It started but it freezed on the mainscreen and both working tested Joy-Cons would not connect to the Switch neither plugged nor wireless. At the second try it recognized the left Joy-Con plugged-in for a short time than it lost connection, while I was unpluging and pluging the right Joy-Con. I a third try it freezed again.

I checked the mentioned cap above the M92T36 again and now it shows a reading…

Calvin i saw a youtube video yesterday and a guy had the same problem with the freeze/no power with both joy con attached…
The problem was that there was a small amout of corrosion and dirt on one of the joy con flex cables

Thank You, Dallas. It was a good hint. I found corrosion at two pins at the right Joy-Con rail. After cleaning both rails both Joy-Cons are working plugged and wireless. Only the ‘Plugging’-Animation for the right one is missing.

Nice!

Im glad that it worked :slight_smile:

I still get no snap animation, if I plug or unplug the right Joy-Con.

I tried the right Joy-Con on an other Switch and the animation shows up. So the Joy-Con should be ok. I tested an other working right Joy-Con and also got no snap animation. I first clean the contacts and second changed the connector in the rail, but no difference.

Does anyone knows which pin is in use to recognize the pluging of the right Joy-Con?

Pins 1&2 are ground, then comes jdet which is high when the joycon is connected over bluetooth and low when it isn’t and then 5v powersupply

check that you have 5v on the 4th pin

I meassured the connector pins right and left:

Values: Joy-Con connected/unconnected
Right Joy-Con

Left Joy-Con

It seems that on the right side a switching is missing.

I tested an other Switch:
How it should be:

Have you checked the protection diode (marking “PU” on the underside, near to the led)
It can also cause this issue
There is another one near it so you have a reference

I checked on the backside the “PU” and “MX” / “ZBL” ics of both Joy-Con ribbon cable connectors and compare it to a fine working Switch. I can t find any difference in continuity and diode mode meassurements. And I have no idea for checking this parts while the Switches are assembled.

I checked the voltages at the connectors again on both Switches and found, that the 5V on the left side are missing if the right Joy-Con is connected…

Does anyone knows where this line goes to? I checked both sides, but I can t find the other end.

Where do you guys get these data sheets from?

Master Calvin makes them, and he is a real hero that share this information for free.

straight up! that is awesome!

Maybe to joycon charge gpio on the soc?
Would be my guess

switchbrew:org/wiki/Bus_services#GpioPadName

I hope it is not a problem with a CPU pin. :stuck_out_tongue:

Is the Tegra soc unique or interchangeable with a Tegra soc from a donor board?