Nintendo logo flash and then nothing

I have a
So early first gen I think.

When I first got it the usb-c port was messed up so I popped in a new one, tested all the pins and everything looks good.
Tried to boot but only the Nintendo logos pops up

Charging amps was finiky and going up and down so
I then swapped out the M92T36 from a donor board seems to charge at both 5v and 14v at 0.5 amps now, but it still shows only the Nintendo logo

I noticed that D+ doesn’t send out any voltage so I traced those lines, verified connectivity and saw they go under the cpu. (:skull:)

When booting also I noticed it stays at the same amps, when usually there is a jump on my other switch.

Just wondering what anybody thinks about this, is there some type of handshake that inst happening for it to send out that small voltage to those lines, or is my CPU fried.

If you stick with PD/original charger, you dont need to care D+ or D- line.
Does it stay 1st logo(NINTENDO), or the logo pops few sec and goes black?

1 Like

Right now the Nintendo logo appears for a few seconds and then goes away

What is the current charge of the battery you are using, have you tested with another known good battery?

Have you taken any readings at the max IC’s, such as the one just south of the cpu?

At the moment ive tested with multiple batteries, LCD’s and emmc’s and tried to boot into sxloader but none of that worked
I did do some readings of that chip but i dont have any working boards to refrence.

Image below of my readings, Nothing apeared to be shorting out assuming the caps at 0.015 are supposed to be like that (i have a cheap multimeter)

It’s weird this diagram is more like a MAX77812 ON V2 OR LITE board rather than MAX77621 on a HAC-CPU-XX board. (OP mentioned HAC-CPU-01).
I would check MAX17050 fuel gauge chip or the BATTERY connector since you have it goes black yet stays on logo.

So above the audio chip and above the ENXX chip i found the below

LOL one side of the cap is gone (this board did have water damage btw)

I only get the nintendo logo for 2 seconds and then it turns off.

ive checked the caps and they look good, in diode mode compared to this image they are a little off.
(Below are my diode mode readings)
Also any recomended ways to test the MAX17050?
Also any recomendations on a good tool to do the diode test my multimeter is cheapie one.

Btw I did change that one cap above the audio chip from dead CPU board I found and it’s still does the same thing

I would reball/replace the ENXX chip. It’s not looking good nearby


I really appreciate your help btw wish I could buy you a coffee or tip you or something, I ordered my stencils a week or two ago they should arrive here soon, I’ll give it a try when they are here, this is gonna be my first reball lil nervous I always ordered the chip just in case.

So I got antsy and didn’t want to wait.
So I threw some amtech on the board and reflowed the fuel gauge chip and then the diode measurements matched my dead CPU board which is also a early version.

Tried to power on and the same thing happened just the Nintendo logo but this time it would only come up once and the never again until I unconnected the battery and then reconnected it and pressed the power button, I also noticed if I plug the battery in and then the charger the charging icon would appear for 2 seconds and then go away.
So I thought it was the bq chip I checked the via diode mode and they were similar to my dead CPU 10 board expect on some caps which I think was dude to the unfixed shorts on that board.

I then was thinking about this one website talking about emmc mismatch issues and failure to boot blah blah using a ociliscope to see if it’s the wrong emmc and failure to decrypt, so I just started swapping the emmcs and I guess I got them mixed up because it booted up fully YAY!

TLDR: getting Nintendo logo every time I pressed the power button, diode measurements were off on the fuel gauge chip, reflowed it then measurements lined up with somewhat same gen board, then I got different symptoms, the Nintendo logo appeared only once unless the battery was connected and reconnected, same with charging icon once charger was connected, swapped emmc to the correct one and it works now. (They got mixed up) (also swapped a ugly cap near the ENxx chip)

@jkyoho @Severence love you thank you for the help, I’m super inexperienced with fixing switches so I really appreciate the help.

1 Like

I also reflowed the ENxx chip and the max chip on the back after it showed improvement but it didn’t fix
the emmc swap fixed it post fuel gauge reflow

1 Like