Nintendo Switch 15V 0A Draw

I purchased a switch on ebay. I swapped out the USB port. Everything started up fine. However, I noticed the BQ chip was getting very hot. I shut down the unit and started testing caps around the BQ. No issues discovered. Tried to turn the unit back on and no boot. Now the unit shows 15v with 0amp draw.

  • Checked caps around M92, no problems
  • Checked USB port with USB tester, no problem
  • Checked around BQ and replaced, still no change
  • Checked voltages and diode readings around, P13, BQ and M92 and MAX chips. Nothing standing out as bad.

I am at a loss with this one. Any ideas would be greatly appreciated.

A working BQ will get hot, there is a little thermal pad in the housing to cool it. What were the original issues when you received the switch? Is the battery working, what is the batt voltage? As I have learned from this forum P13 is for docking and shouldn’t affect charging. If you are getting 15v then M92 should be fine. It may be possible you got a faulty new BQ chip, where did you get it from? Check the forums, there are tons of pictures showing how to test BQ. Also, upload good-quality pictures of the board and your work just to get a visual idea of how it looks. Also was there any prior work to the board that you can tell?