Nintendo Switch no display, slow charging, only 0.4A

Hello good evening mate.
First of all i am new here so nice to meet you.
Anyway i have a question regarding my switch.

So 3 days ago i was charging my switch but suddenly it turn off and no sign of life. I tried to look for it in internet and already tried several attempt fix like let it charge overnight, change cable, use docking, and change battery but all failed. I tried to open my switch and use multi meter to check if there’s any short on IC M92T36, P13USB, and BQ2413 but no short detected. I check the voltage and the amp, 5V but only got 0.4A for the amp, means it charging the battery but in slow charge mode. I tried running TegraMCGUI, it does detect my switch but my switch already patched so i can’t try the payload method. In desperate attempt i tried replace the M92T36 only to make the amp fall to 0A. And to make matter worse i lost the tiny capacitor (between the 2 regulator above the charging port). My question is there any possible fix on this case?, does my new M92T36 defect (i only have 1 at the moment)?, and can anyone tell me the value of capacitor that i lost?.

Thanks in advance for everyone reading this and give some feedback to me

Not complet, but maybe helpfull.

1 Like

thank you so much calvin, atleast i know the initial value for the missing capacitor

edit : my mistake the capacitor that missing isn’t in the picture that you gave me, but nevertheless i really thank you for your help and by the way how do i post picture like you, i tried to upload the original location for the missing capacitor but failed

i tried to but a popup notification say *sorry you can’t put image in a post

I hope it is now in the picture. :slight_smile:

1 Like

YES!!, thank you so much calvin!, this really help me, just how did you do that?. I’ve been looking for this in other forum but no avail.
I really love this community. Calvin you’re the best
About my case regarding the 0.4A and 0A, there’s no progress but at least i don’t have any setback, for now. I’ll inform in here if there’s any progress regarding the case.

Hi xfreaks,

Switches stuck on 0.4A are generally a sign of a failure at the initial boot stages. In most cases you’ll be met with no screen, backlight etc.

My typical areas to investigate in these cases are:

  • PMIC power rail shorts [MAX77620],
  • Faulty fuel gauge IC [MAX17050],
  • CPU buck failure [MAX77621],
  • Battery sense wire connection failure,
  • EMMC failure/missing/corrupted and
  • being stuck in AutoRCM mode

Good luck!

Thanks @SheriffBuck, the last 3 is seldom happen to me, my best shot usually is to replace the fuel gauge. Sometimes work, sometimes doesn’t. In any case thanks for the reply, i’ll include it on my next repair if i encounter such case again