Nintendo switch no hdmi output

Hi, I know this has been asked a a lot of times I tried posting on others threads with no replies.

Anyway I have a Nintendo switch with no hdmi output. It started out as a messed up charge port. So after changing the port, the unit won’t turn on. Replaced p13usb ic, unit
seems fine, but after testing the dock no output.

When switch is docked the screen turn black and green light turn on. But no signal.

Any help will be appreciated


There is a lot to rule out here but I would start with using a different dock, hdmi cable and tv.

If that doesn’t solve the issue remove the board check all the pads around the P13USB are soldered properly(microscope needed).

If the connections look good and the chip is sitting flat you need to check to make sure all the chokes have continuity from one side to the other.

I just fixed one myself that had a burnt trace from one of the chokes to P13USB.

Well I don’t have a microscope. I have lifted the p13usb twice seems to be flat. Seems like the traces are all intact. I replaced all the chokes one was bad. The dock is good. I tried a different switch and it was able to output display. IL try to check all the other components near the p13usb chip

Try a usb breakout board and see if you hidden row of pads makes contact.

I cannibalize a usb type c port. I have tested the pins in diode mode. I got these values on both sides of the charge port. I have ordered a break out board but hasn’t arrived yet. IL test again when it arrives

G OL OL .499.712.749.748.478.499 OL OL G

seems to be way off from fxdx reference values

The values are like I would expect at the usb-c pins.

I’m having doubts on my hot air skills. IL try to resolder the p13usb. Also did anyone encounter a defective replacement p13usb chip?

NOT SEEN. Compared to fake/bad refurb M92T36, Pi3usb has lower chance got a bad one

Wow didn’t know there were refurb m92t36. Anyway my unit is working now.

Turns out it was bad solder after all. It’s really hard working with just magnifying glass as I don’t have a microscope. I resolder the p13usb and viola like magic it fixed the problem.

Thanks to every one that replied to my thread :slight_smile: